Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Data Protection Advisor: Oppgraderingen er vellykket, men applikasjonen starter ikke og må startes på nytt manuelt for å begynne å fungere

Summary: Data Protection Advisor: Oppgraderingen var vellykket, men applikasjonen starter ikke og må startes på nytt manuelt for å begynne å fungere.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Oppgraderingsinstallasjonen av Data Protection Advisor (DPA) fullføres uten problemer på DPA-datalageret (DS) og DPA-applikasjonen (app).

Når DPA-appoppgraderingen er fullført, skal den kjøre oppgraderingsskriptene og starte.
I dette tilfellet mislykkes DPA-appen med meldingen «DPA Master failed to start» (DPA Master kunne ikke starte).
DPA-appstatusen viser at den er stoppet.

Hvis DPA-appen startes manuelt på nytt, starter den som normalt.

DPA-oppgraderingsloggen rapporterer:

Input validation failed for object Schedule Original message: schedule is used in DC requests datadomain/analysis. Updated definition is invalid: "Point in time" schedules are only supported

Feilen identifiserer datadomene-/analyseforespørsler for Data Domain-datainnsamling og en tidsplan.

Data Domain-analyseforespørsler konfigureres identisk og bruker samme tidsplan. Andre forespørsler bruker også denne tidsplanen.
 

Tidsplaner-skjermbilde


Tidsplanen og konfigurasjonen ser ut til å være riktig. Dette er en tidsplan for punkt i tid.
 

Planlegg skjermbilde

Planlegg egenskaper

 
 
 

Cause

Dette er en kjent feil i Data Protection Advisor.

Årsaken er ikke bekreftet.
Det er mistanke om at en standard DPA-systemplan har blitt endret ved et uhell av en bruker. Standard systemplan har navnet "always" (alltid).

Tidsplanen forventes å være til stede og av en bestemt type når DPA-appen kjører oppgraderingsskriptene.
Dette fører til at feilen logges, og at DPA-appen ikke starter første gang etterpå.

På det neste DPA-appstartforsøket kjøres ikke lenger oppgraderingsskriptene. DPA-appen støter ikke på dette problemet og starter på vanlig måte.

Atferden vises på nytt ved neste DPA-oppgradering.
 

Resolution

Det er ingen løsning på dette problemet for øyeblikket.

Løsningen: 

Den eksisterende DPA-planen som fører til dette problemet, må slettes og erstattes med en nylig opprettet tidsplan. Dette må gjøres for alle forespørsler om datainnsamling som bruker denne problemplanen.

Instruksjoner:

  1.  I DPA-grensesnittet undersøker du alle sannsynlige objekter (i dette eksempelet Data Domains) og identifiserer om denne tidsplanen er tilordnet.
  2. Fjern denne tidsplanen fra alle forespørsler, og tilordne en annen tidsplan eller opprett en ny tidsplan med identiske detaljer
  3. I DPA-grensesnittet går du til System og planlegger
  4. Slett problemplanen (i vårt eksempel, 0800–torsdag)

MERK: Kontroller at alle sannsynlige objekter og bruken av timeplanen er bestemt, og at tidsplanen er fjernet/erstattet.
Hvis noen av problemplanene ikke fjernes eller erstattes, kan datainnsamlingsforespørselen mislykkes eller forårsake uforutsigbar atferd.

Etter at du har fullført disse trinnene, fullføres neste oppgradering av DPA på vanlig måte.
DPA-appen skal starte som vanlig. Standard systemplan vil bli opprettet på nytt under oppgraderingen.
Du skal heller ikke lenger se feilmeldingen ved å undersøke DPA upgrade.log.

Hvis disse trinnene ikke løser problemet, eller hvis problemplanen ikke kan identifiseres, kan du kontakte Dells tekniske kundestøtte.

Article Properties
Article Number: 000215753
Article Type: Solution
Last Modified: 26 Oct 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.