Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Data Protection Advisor: Aktualizacja powiodła się, ale nie można uruchomić aplikacji i należy ponownie uruchomić ponownie ręcznie, aby rozpocząć pracę

Summary: Data Protection Advisor: Aktualizacja powiodła się, ale nie można uruchomić aplikacji i aby rozpocząć pracę, należy ponownie uruchomić aplikację ręcznie.

This article applies to   This article does not apply to 

Symptoms

Instalacja uaktualnienia Data Protection Advisor (DPA) kończy się bez problemu w sklepie danych DPA (DS) i aplikacji DPA (aplikacja).

Po zakończeniu uaktualniania aplikacji DPA należy uruchomić skrypty aktualizacji i uruchomić ją.
W takim przypadku uruchomienie aplikacji DPA kończy się niepowodzeniem z komunikatem "Nie można uruchomić narzędzia DPA Master".
Stan aplikacji DPA pokazuje go w stanie zatrzymania.

Jeśli aplikacja DPA jest uruchamiana ręcznie ponownie, uruchamia się normalnie.

Dziennik aktualizacji DPA raportuje:

Input validation failed for object Schedule Original message: schedule is used in DC requests datadomain/analysis. Updated definition is invalid: "Point in time" schedules are only supported

Błąd identyfikuje wnioski o gromadzenie danych datadomain/analizy w Domenie danych oraz harmonogram.

Żądania analizy Data Domain są skonfigurowane identycznie i korzystają z tego samego harmonogramu. Inne żądania również korzystają z tego harmonogramu.
 

Ekran Harmonogramy


Harmonogram i konfiguracja wydają się być poprawne. Jest to harmonogram czasowy.
 

Zaplanuj zrzut ekranu

Zaplanuj właściwości

 
 
 

Cause

Jest to znana wada rozwiązania Data Protection Advisor.

Przyczyna nie została potwierdzona.
Istnieje podejrzenie, że domyślny harmonogram systemu DPA został przypadkowo zmodyfikowany przez użytkownika. Domyślny harmonogram systemu nosi nazwę "zawsze".

Harmonogram powinien być obecny i pewnego typu, gdy aplikacja DPA uruchamia skrypty aktualizacji.
Powoduje to, że błąd jest rejestrowany, a aplikacja DPA nie uruchamia się po raz pierwszy.

Przy następnej próbie uruchomienia aplikacji DPA skrypty aktualizacji nie są już uruchamiane. Aplikacja DPA nie napotka tego problemu i uruchamia się normalnie.

Zachowanie będzie widoczne ponownie przy następnej aktualizacji DPA.
 

Resolution

Obecnie nie ma rozwiązania tego problemu.

Obejście: 

Istniejący harmonogram DPA prowadzący do tego problemu musi zostać usunięty i zastąpiony nowo utworzonym harmonogramem. Należy to zrobić dla wszystkich próśb o gromadzenie danych, które korzystają z tego harmonogramu problemów.

Instrukcje:

  1.  W interfejsie użytkownika DPA sprawdź wszystkie prawdopodobne obiekty (w tym przykładzie Domeny danych) i sprawdź, czy został przypisany ten harmonogram.
  2. Usuń ten harmonogram ze wszystkich żądań i przypisz inny harmonogram lub utwórz nowy harmonogram z identycznymi szczegółami
  3. W interfejsie użytkownika DPA przejdź do systemu, a następnie zaplanuj
  4. Usuń harmonogram problemu (w naszym przykładzie, 0800–czwartek)

UWAGA: Dopilnowanie, aby wszystkie prawdopodobne obiekty i zastosowania Harmonogramu zostały określone, a harmonogram został usunięty/zastąpiony.
Jeśli którykolwiek z problemów z harmonogramem nie zostanie usunięty lub zastąpiony, żądanie gromadzenia danych może zakończyć się niepowodzeniem lub spowodować nieprzewidywalne zachowanie.

Po wykonaniu tych czynności następna aktualizacja DPA zostanie ukończona normalnie.
Aplikacja DPA powinna uruchomić się w zwykły sposób. Podczas aktualizacji zostanie utworzony domyślny harmonogram systemu.
Należy również pamiętać, że plik DPA upgrade.log nie powinien już wyświetlać komunikatu o błędzie.

Jeśli wykonanie tych czynności nie rozwiązało problemu lub nie można zidentyfikować harmonogramu problemu, skontaktuj się z działem pomocy technicznej firmy Dell.

Article Properties
Article Number: 000215753
Article Type: Solution
Last Modified: 26 Oct 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.