Symptoms
SupportAssist Client v3.1 may encounter a version mismatch error where either Appx is a higher version or the service is a higher version.
Cause
This may be caused by a miscommunication of the SupportAssist compatible OS version due to a required module not being present on the machine.
Resolution
To resolve this issue, please follow the instructions below:
-
Run Windows Update:
- Right click the Windows Start Button and select Search.
- Search for "Windows Update Settings" and then open Windows Update Settings.
- Click on Update & Security .
- Click on Check for Updates.
- Download and install all available updates.
-
Download and install the latest version of SupportAssist:
- Navigate to the SupportAssist home page: https://www.dell.com/en-us/shop/supportassistforpcs/cp/supportassistforpcs
- Click on Download Now button.
The latest version of AppX is installed automatically with the current version of SupportAssist. All version mismatch errors should be resolved with the update.