Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

NetWorker:バックアップEメール通知が受信されない「SMTPホストへの接続に失敗しました: No such file or directory」

Summary: NetWorkerバックアップEメール通知は構成されますが、Eメールは受信されません。バックアップ ワークフロー ログには、SMTPホストへの接続障害が表示されます。

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

  • オペレーティング システム ベースのEメール コマンドはポリシー/ワークフロー レベルで構成されますが、完了/失敗時にメール通知が受信されません。
  • ワークフロー「メッセージの表示」では、「connect to SMTP host failed: No such file or directory」
MM/DD/YYYY HH:MM:SS Starting Protection Policy 'Server Protection' workflow 'Server backup'.
MM/DD/YYYY HH:MM:SS Starting action 'Server Protection/Server backup/Server db backup' with command: 'nsrdbsave -l 1'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Server db backup's log will be in 'C:\Program Files\EMC NetWorker\nsr\logs\policy\Server Protection\Server backup\Server db backup_449081.raw'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Server db backup' succeeded.
MM/DD/YYYY HH:MM:SS Starting action 'Server Protection/Server backup/Expiration' with command: 'nsrim -MXq'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Expiration's log will be in 'C:\Program Files\EMC NetWorker\nsr\logs\policy\Server Protection\Server backup\Expiration_449095.raw'.
connect to SMTP host failed: No such file or directory
connect to SMTP host failed: No such file or directory
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Expiration' succeeded.
MM/DD/YYYY HH:MM:SS Workflow 'Server Protection/Server backup' succeeded.

Cause

SMTPポート25がブロックされています。

Resolution

NetWorkerは、オペレーティング システム コマンドを使用してEメールを送信します。Eメールは、NetWorker内から送信する前に、オペレーティング システムから正常に送信する必要があります。NetWorkerサーバーとメール サーバー間の潜在的な通信の問題を特定するためのトラブルシューティング手順を次に示します。
  1. 次のコマンド ラインからNetWorkerサーバーのオペレーティング システムからEメールを正常に送信する必要があります。
Linux: ls -lh | mail -s mailserver-name-or-ip -s "subject" recipient-email-address
Windows:DIR |smtpmail -h mailserver-name-or-ip -s "subject" recipient-email-address

メモ: 上記のコマンドでは、斜体の値を環境の対応する情報に置き換えます。これらのコマンドが正常に実行されると、プロンプトが返され、ディレクトリ リストを含むEメールが コマンドで指定されたメール アドレスに送信されます。
  1. ドメインのMXレコードを使用してサーバーを検索できるメール サーバー アドレスがわからない場合は、次の手順を実行します。
Linux: dig your_domain.com MX
Windows: Nslookup
q=mx
your_domain.comの設定
  1. NetWorkerサーバーは、メール サーバーの完全修飾ドメイン名(FQDN)、短い名前、IPアドレス:nslookup mailserver-nameを解決できる必要があります。
メモ: NetWorkerサーバーがDNSを介してメール サーバーを解決できない場合は、そのDNSエントリーを作成または修正します。それ以外の場合は、メール サーバーのIPアドレスとホスト名をNetWorkerサーバーのローカル ホスト ファイルに追加します。

Linuxの場合/etc/hosts
Windows: C:\Windows\System32\drivers\etc\hosts
  1. NetWorkerサーバーは、ICMP pingを介してメール サーバーに到達する必要があります。 ping mailserver-name
  2. NetWorkerサーバーは、メール サーバーのSMTPポート(ポート25)に到達する必要があります。 nsrports -t mailserver-name -p 25
C:\Windows\system32>nsrports -t mailserver.domain.com -p 25
Forward lookup for mailserver
Query time:              0.001 sec
Canonical name (CNAME):  mailserver.domain.com
Address (A):             10.0.0.2
Connect to port 25:      Succeeded (0.088 sec)

Reverse lookup for 10.0.0.2
Query time:              0.000 sec
Name:                    mailserver.domain.com
メモ: nsrportsは、NetWorkerサーバー ソフトウェアとともにインストールされるNetWorkerコマンドです。このコマンドは、任意のNetWorkerサーバーで使用でき、名前解決とポート接続の検証に使用できます。

Additional Information

Article Properties


Affected Product

NetWorker

Product

NetWorker

Last Published Date

06 Oct 2023

Version

3

Article Type

Solution