Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

NetWorker: Las notificaciones por correo electrónico de respaldo que no se reciben "connect to SMTP host failed: No such file or directory”

Summary: Las notificaciones por correo electrónico de respaldo de NetWorker están configuradas, pero no se recibe ningún correo electrónico. Los registros del flujo de trabajo de respaldo muestran una falla de conexión con el host SMTP. ...

This article applies to   This article does not apply to 

Symptoms

  • Los comandos de correo electrónico basados en el sistema operativo se configuran en el nivel de política/flujo de trabajo, pero no se reciben notificaciones por correo electrónico tras la finalización/falla.
  • El flujo de trabajo "Show Messages" informará "connect to SMTP host failed: No such file or directory”
MM/DD/YYYY HH:MM:SS Starting Protection Policy 'Server Protection' workflow 'Server backup'.
MM/DD/YYYY HH:MM:SS Starting action 'Server Protection/Server backup/Server db backup' with command: 'nsrdbsave -l 1'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Server db backup's log will be in 'C:\Program Files\EMC NetWorker\nsr\logs\policy\Server Protection\Server backup\Server db backup_449081.raw'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Server db backup' succeeded.
MM/DD/YYYY HH:MM:SS Starting action 'Server Protection/Server backup/Expiration' with command: 'nsrim -MXq'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Expiration's log will be in 'C:\Program Files\EMC NetWorker\nsr\logs\policy\Server Protection\Server backup\Expiration_449095.raw'.
connect to SMTP host failed: No such file or directory
connect to SMTP host failed: No such file or directory
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Expiration' succeeded.
MM/DD/YYYY HH:MM:SS Workflow 'Server Protection/Server backup' succeeded.

Cause

Se está bloqueando el puerto SMTP 25.

Resolution

NetWorker utiliza comandos del sistema operativo para enviar correos electrónicos. Los correos electrónicos se deben enviar correctamente desde el sistema operativo antes de que se puedan enviar desde NetWorker. Los siguientes son algunos pasos de solución de problemas para aislar un posible problema de comunicación entre el servidor de NetWorker y el servidor de correo.
  1. Los correos electrónicos se deben enviar correctamente desde el sistema operativo del servidor NetWorker desde la línea de comandos:
Linux: ls -hl | mail -s mailserver-name-or-ip -s "subject" recipient-email-address
Windows: DIR | smtpmail -h mailserver-name-or-ip -s "subject" recipient-email-address

NOTA: En los comandos anteriores, reemplace los valores cursiva con la información correspondiente de su ambiente. Si estos comandos se ejecutan correctamente, el indicador regresa y se envía un correo electrónico con una lista de directorios a la dirección de correo electrónico especificada en el comando.
  1. Si no conoce la dirección del servidor de correo que puede intentar buscar en el servidor mediante el registro MX para su dominio:
Linux: dig your_domain.com MX
Windows: Nslookup
establecer q=mx
your_domain.com
  1. El servidor de NetWorker debe poder resolver el nombre de dominio calificado (FQDN), el nombre corto y la dirección IP del servidor de correo: nslookup mailserver-name
NOTA: Si el servidor de NetWorker no puede resolver el servidor de correo a través de DNS, cree o corrija la entrada de DNS para él; de lo contrario, agregue la dirección IP y el nombre de host del servidor de correo al archivo de hosts locales del servidor NetWorker:

Linux: /etc/hosts
Windows: C:\Windows\System32\drivers\etc\hosts
  1. El servidor de NetWorker debe comunicarse con el servidor de correo a través de ping de ICMP: ping mailserver-name
  2. El servidor de NetWorker debe alcanzar el puerto SMTP del servidor de correo (puerto 25): nsrports -t mailserver-name -p 25
C:\Windows\system32>nsrports -t mailserver.domain.com -p 25
Forward lookup for mailserver
Query time:              0.001 sec
Canonical name (CNAME):  mailserver.domain.com
Address (A):             10.0.0.2
Connect to port 25:      Succeeded (0.088 sec)

Reverse lookup for 10.0.0.2
Query time:              0.000 sec
Name:                    mailserver.domain.com
NOTA: nsrports es un comando de NetWorker que se instala con el software del servidor de NetWorker. Este comando está disponible para su uso en cualquier servidor de NetWorker y se puede utilizar para validar la resolución de nombres y la conectividad de puertos.

Additional Information

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000060536
Article Type: Solution
Last Modified: 06 Oct 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.
Article Properties
Article Number: 000060536
Article Type: Solution
Last Modified: 06 Oct 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.