Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

NetWorker: Notifiche e-mail di backup non ricevute "connect to SMTP host failed: No such file or directory"

Summary: Le notifiche e-mail di backup di NetWorker sono configurate, ma non viene ricevuta alcuna e-mail. I log del workflow di backup mostrano un errore di connessione all'host SMTP.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

  • I comandi e-mail basati sul sistema operativo sono configurati a livello di policy/workflow, ma la notifica email non viene ricevuta al completamento/errore.
  • Il workflow "Show Messages" indicherà "connect to SMTP host failed: No such file or directory"
MM/DD/YYYY HH:MM:SS Starting Protection Policy 'Server Protection' workflow 'Server backup'.
MM/DD/YYYY HH:MM:SS Starting action 'Server Protection/Server backup/Server db backup' with command: 'nsrdbsave -l 1'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Server db backup's log will be in 'C:\Program Files\EMC NetWorker\nsr\logs\policy\Server Protection\Server backup\Server db backup_449081.raw'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Server db backup' succeeded.
MM/DD/YYYY HH:MM:SS Starting action 'Server Protection/Server backup/Expiration' with command: 'nsrim -MXq'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Expiration's log will be in 'C:\Program Files\EMC NetWorker\nsr\logs\policy\Server Protection\Server backup\Expiration_449095.raw'.
connect to SMTP host failed: No such file or directory
connect to SMTP host failed: No such file or directory
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Expiration' succeeded.
MM/DD/YYYY HH:MM:SS Workflow 'Server Protection/Server backup' succeeded.

Cause

La porta SMTP 25 è bloccata.

Resolution

NetWorker utilizza i comandi del sistema operativo per l'invio di e-mail. Le e-mail devono essere inviate correttamente dal sistema operativo prima che possano essere inviate da NetWorker. Di seguito sono riportati alcuni passaggi per la risoluzione di un potenziale problema di comunicazione tra il server NetWorker e il server di posta.
  1. Le e-mail devono essere inviate correttamente dal sistema operativo del server NetWorker dalla riga di comando:
Linux: ls -lh | mail -s mailserver-name-or-ip -s "subject" recipient-email-address
Finestre: Dir | smtpmail -h mailserver-name-or-ip -s "subject" recipient-email-address

NOTA: Nei comandi precedenti, sostituire i valori corsivo con le informazioni corrispondenti del proprio ambiente. Se questi comandi hanno esito positivo, viene restituito il prompt e viene inviata un'e-mail con un elenco di directory all'indirizzo e-mail specificato nel comando.
  1. Se non si conosce l'indirizzo del server di posta, è possibile cercare il server utilizzando il record MX per il dominio:
Linux: dig your_domain.com MX
Windows: Nslookup
impostare q=mx
your_domain.com
  1. Il server NetWorker deve essere in grado di risolvere il nome di dominio completo (FQDN), il nome breve e l'indirizzo IP del server di posta: nslookup mailserver-name
NOTA: Se il server NetWorker non è in possibile risolvere il server di posta tramite DNS, creare o correggere la relativa voce DNS; In caso contrario, aggiungere l'indirizzo IP e il nome host del server di posta al file host locale del server NetWorker:

Linux: /etc/hosts
Windows: C:\Windows\System32\drivers\etc\hosts
  1. Il server NetWorker deve raggiungere il server di posta tramite ping ICMP: ping mailserver-name
  2. Il server NetWorker deve raggiungere la porta SMTP del server di posta (porta 25): nsrports -t mailserver-name -p 25
C:\Windows\system32>nsrports -t mailserver.domain.com -p 25
Forward lookup for mailserver
Query time:              0.001 sec
Canonical name (CNAME):  mailserver.domain.com
Address (A):             10.0.0.2
Connect to port 25:      Succeeded (0.088 sec)

Reverse lookup for 10.0.0.2
Query time:              0.000 sec
Name:                    mailserver.domain.com
NOTA: nsrports è un comando NetWorker che viene installato con il software del server NetWorker. Questo comando è disponibile per l'utilizzo su qualsiasi server NetWorker e può essere utilizzato per convalidare la risoluzione dei nomi e la connettività delle porte.

Additional Information

Article Properties


Affected Product

NetWorker

Product

NetWorker

Last Published Date

06 Oct 2023

Version

3

Article Type

Solution