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NetWorker: Backup Email Notifications Not Being Received "connect to SMTP host failed: No such file or directory"

Summary: NetWorker backup email notifications are configured but no email is received. The backup workflow logs show a connection failure to the SMTP host.

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Article Content


Symptoms

  • Operating System based email commands are configured at the policy/workflow level but email notification is not being received upon completion/failure.
  • The Workflow "Show Messages" will report "connect to SMTP host failed: No such file or directory"
MM/DD/YYYY HH:MM:SS Starting Protection Policy 'Server Protection' workflow 'Server backup'.
MM/DD/YYYY HH:MM:SS Starting action 'Server Protection/Server backup/Server db backup' with command: 'nsrdbsave -l 1'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Server db backup's log will be in 'C:\Program Files\EMC NetWorker\nsr\logs\policy\Server Protection\Server backup\Server db backup_449081.raw'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Server db backup' succeeded.
MM/DD/YYYY HH:MM:SS Starting action 'Server Protection/Server backup/Expiration' with command: 'nsrim -MXq'.
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Expiration's log will be in 'C:\Program Files\EMC NetWorker\nsr\logs\policy\Server Protection\Server backup\Expiration_449095.raw'.
connect to SMTP host failed: No such file or directory
connect to SMTP host failed: No such file or directory
MM/DD/YYYY HH:MM:SS Action 'Server Protection/Server backup/Expiration' succeeded.
MM/DD/YYYY HH:MM:SS Workflow 'Server Protection/Server backup' succeeded.

Cause

SMTP port 25 is being blocked.

Resolution

NetWorker uses operating system commands for sending emails. Emails should be successfully sent from the operating system before they can be sent from within NetWorker. The Following are some troubleshooting steps for isolating a potential communication issue between the NetWorker server and mail server.
  1. Emails should be successfully sent from the NetWorker server's operating system from command line:
Linux: ls -lh | mail -s mailserver-name-or-ip -s "subjectrecipient-email-address
Windows: DIR | smtpmail -h mailserver-name-or-ip -s "subjectrecipient-email-address

NOTE: In the above commands, replace the italic values with the corresponding information from your environment. If these commands are successful the prompt returns and an email with a directory listing is sent to the email address specified in the command.
  1. If you do not know the mail server address that you can try to lookup the server using the MX record for your domain:
Linux: dig your_domain.com MX
Windows: nslookup
set q=mx
your_domain.com
  1. The NetWorker server must be able to resolve the mail server's Fully Qualified Domain Name (FQDN), shortname, IP address: nslookup mailserver-name
NOTE: If the NetWorker server cannot resolve the mail server through DNS then create or correct the DNS entry for it; otherwise, add the mail server's IP address and hostname to the NetWorker server's local hosts file:

Linux: /etc/hosts
Windows: C:\Windows\System32\drivers\etc\hosts
  1. The NetWorker server must reach the mail server over ICMP ping: ping mailserver-name
  2. The NetWorker server must reach the mail server's SMTP port (port 25): nsrports -t mailserver-name -p 25
C:\Windows\system32>nsrports -t mailserver.domain.com -p 25
Forward lookup for mailserver
Query time:              0.001 sec
Canonical name (CNAME):  mailserver.domain.com
Address (A):             10.0.0.2
Connect to port 25:      Succeeded (0.088 sec)

Reverse lookup for 10.0.0.2
Query time:              0.000 sec
Name:                    mailserver.domain.com
NOTE: nsrports is a NetWorker command that gets installed with the NetWorker server software. This command is available for use on any NetWorker server and can be used to validate name resolution and port connectivity.

Additional Information

Article Properties


Affected Product

NetWorker

Product

NetWorker

Last Published Date

06 Oct 2023

Version

3

Article Type

Solution