Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Latitude 5420 and 5520s Report an Error When Running the Intel Thunderbolt Firmware Update

Summary: Information about an Intel Thunderbolt firmware update error on Latitude 5420 or 5520s with the Intel (11th generation Tiger Lake) processor.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

"This program does not contain a valid System Thunderbolt Firmware Payload" error when running the Intel Thunderbolt firmware utility.

Cause

Firmware utility does not support the Intel (11th Generation Tiger Lake) processor.

Resolution

Thunderbolt Firmware Utility Error

Latitude 5420 and 5520 computers may experience an error message when attempting to install the Intel Thunderbolt Firmware update. This may occur with the most recent Thunderbolt driver update. (Figure 1.)


This error only occurs on Latitude 5420 and 5520 computers that are built with Intel (11th generation Tiger Lake) Processors.
Dell Thunderbolt Firmware Utility
Figure 1 - Error: This program does not contain a valid System Thunderbolt Firmware Payload.

Latitude 5420 and 5520 computers use two generations of Intel Processors (10th Generation Comet Lake and 11th Generation Tiger Lake). The Intel Thunderbolt Firmware Update only applies to the Comet Lake processors. In Tiger Lake configurations, the Thunderbolt Firmware is integrated into the BIOS.


BIOS Update

Updating to the latest BIOS version on the computer will keep the Thunderbolt Firmware up to date. To download and install the latest BIOS version:

 
WARNING: Dell recommends disconnecting devices such as external hard drives, printers, scanners, and so on, before updating the BIOS.

Dell laptops must have the battery installed and charged to at least 10% before you begin the BIOS update. Dell recommends connecting the laptop to AC power before proceeding with the update process.
 
NOTE: To learn more about updating the BIOS on a Dell computer, see the Dell knowledge base article Dell BIOS Updates.

To install the BIOS, your User account must have Administrator privileges.
 
  1. Browse to Dell.com/Support/Drivers.
  2. Identify your Dell computer.
    1. Click Download & Install SupportAssist to auto-detect your Dell computer. Follow the on-screen instructions to install Dell SupportAssist. For more information, see the Dell knowledge base article: Dell SupportAssist (formerly Dell System Detect): Overview and Common Questions
    2. Enter the Service Tag of the laptop and click Search.
    3. Or, click Browse all products and select your Dell computer from the catalog.
  3. Select the Operating System that is installed on the Dell computer.
  4. Under Category, select BIOS.
  5. Locate the latest System BIOS.
  6. Click Download and save the file to your computer.
  7. Open File Explorer and browse to the location where the downloaded file is saved.
  8. Double-click the BIOS setup file and follow the on-screen instructions to complete the installation process.

Article Properties


Affected Product

Latitude 5520, Latitude 5420

Last Published Date

20 Aug 2021

Version

2

Article Type

Solution