メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能

Elevado uso de memória devido a SupportAssistAgent.exe

概要: Este artigo fornece informações sobre SupportAssistAgent.exe causando alto uso de memória (>90%) no Gerenciador de Tarefas.

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Produtos afetados:

  • SupportAssist for Home PCs

Versões afetadas:

  • v3.13.x
  • v3.14.x

Plataformas afetadas:

  • Alienware
  • Série G
  • OptiPlex
  • Latitude
  • Inspiron
  • Precision Workstations
  • Vostro
  • XPS

Em algumas máquinas, o SupportAssist v3.13.x e 3.14.x provoca uma elevada utilização da memória. Quando este fenómeno ocorre, o Gestor de Tarefas mostra a percentagem >de utilização de memória de 90%.

Isso pode afetar o desempenho do computador enquanto às vezes o computador pode parar de responder e a tela fica preta.

Gestor de Tarefas a mostrar SupportAssistAgent.exe elevada utilização de memória
Figura 1: (Apenas em inglês) Gestor de Tarefas a mostrar SupportAssistAgent.exe elevada utilização de memória

原因

A conexão IoT é feita usando o SDK do Microsoft Azure, que está causando o vazamento de memória.

解決方法

O problema foi resolvido com a última versão v4.0.3.

  • A versão mais recente é atualizada automaticamente ou recebe um pedido para atualizar quando abre a Interface de Utilizador do SupportAssist.
  • Pode atualizar manualmente a versão, para obter mais informações consulte Explore o SupportAssist para PCs de Casa.

As plataformas listadas abaixo não podem ser atualizadas automaticamente para o SupportAssist v4.0.3.

Plataformas temporariamente excluídas:

Plataformas
Dell G15 5530
Dell G16 7630
Inspiron 14 5440
Inspiron 14 5445
Inspiron 14 7440 2 em 1
Inspiron 15 3520
Inspiron 15 3530
Inspiron 16 5640
Inspiron 16 5645
Vostro 14 3430
Vostro 15 3530
Vostro 16 5640
Vostro 3420
Vostro 3520
Nota: Os usuários com essas plataformas ainda podem atualizar seguindo as etapas abaixo.

Passos para transferir e instalar manualmente o SupportAssist v4.0.3:

  1. Instale o tempo de execução mais recente da área de trabalho .NET: https://dotnet.microsoft.com/download/dotnet/6.0 Esse hiperlink direcionará você para um site fora da Dell Technologies.

Tempo de execução do .NET Desktop 6.0.29
Figura 2: (Apenas em inglês) .NET Desktop Runtime 6.0.29

  1. Para encontrar o Tipo de Sistema, procure Informações do Sistema na barra de pesquisa do Windows.

Informações do sistema
Figura 3: (Somente em inglês) Informações do sistema

  1. Transfira o .msi SupportAssist (SupportAssistx64-4.0.3.61632.msi) mais recente do Catálogo de Transferências da Dell.
  2. Transfira o .msp mais recente do SupportAssist (SupportAssistx64-4.0.3.61632.msp) do Catálogo de Transferências da Dell.
  3. Crie uma pasta na unidade C e nomeie-a como SA.
  4. Copie os arquivos .msi e .msp baixados para a pasta SA na unidade C.
  5. Abrir Linha de Comandos como Administrador
    1. Digite msiexec /i C:\SA\SupportAssistx64-4.0.0.61632.msi /qb /l*v e pressione Enter. Aguarde a conclusão da instalação do .msi.

.msi janela de instalação.
Figura 4: (Apenas em inglês) .msi janela de instalação.

  1. Digite msiexec /p C:\SA\SupportAssistx64-4.0.3.61632.msp /qb /l*v e pressione Enter. Aguarde a conclusão da instalação .msp.

Janela de instalação .msp
Figura 5: (Apenas em inglês) Janela de instalação .msp

  1. Aceda a Programas e abra a aplicação SupportAssist.

その他の情報

対象製品

Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations, Mobile Workstations, SupportAssist for Home PCs
文書のプロパティ
文書番号: 000223371
文書の種類: Solution
最終更新: 30 5月 2024
バージョン:  5
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。