Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Avamar: "A Java Exception has occurred" error when trying to launch Avamar Administrator

Summary: Avamar: "A Java Exception has occurred" error when trying to launch Avamar Administrator.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Environment:
  • Windows 7 (64 bit)
  • Avamar server v7.4.0-177
  • Java Release: 1.8.0_102 64 bit (downloaded from the Avamar server Downloads page)
When launching the Avamar Administrator, before the login screen appears we see;
A Java Exception has occurred:

We see a pop-up reporting A Java Exception has occurred:

Windows > Control Panel > Java control panel >  Java shows that versions 1.7 and 1.8 are installed:
Java shows that versions 1.7 and 1.8 are installed:

If we right-click the program launcher shortcut in 
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\EMC Avamar\Administrator\<version>

The "target location" field points to jre7.
"C:\Program Files (x86)\avs\administrator\7.4.0.177\bin\mcgui.bat" C:\PROGRA~2\Java\jre7

Cause

Java 8 was not installed or had been installed after Avamar Administrator software was installed.

Resolution

  1. Uninstall the Avamar Administrator v7.4 software.
  2. Install the Java release provided on the Avamar Administrator downloads page (http://avamarservername/) > Downloads
  3. Reinstall the Avamar Administrator v7.4 software.

    Article Properties


    Affected Product

    Avamar

    Product

    Avamar

    Last Published Date

    16 Aug 2023

    Version

    3

    Article Type

    Solution