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NVP vProxy: Risoluzione dei problemi delle istantanee VMware durante i backup di NetWorker.

Summary: Questo articolo della KB è destinato come riferimento per il supporto e gli amministratori di NetWorker in merito ai backup delle VM eseguiti tramite l'appliance NVP vProxy. I backup delle VM hanno esito negativo con un errore relativo alle istantanee. ...

This article applies to   This article does not apply to 

Symptoms

  • Le VM VMware sono protette tramite l'appliance vProxy NetWorker VMware Protection (NVP).
  • I backup hanno esito negativo con un errore relativo alle snapshot. È possibile che vengano visualizzate alcune varianti degli errori delle istantanee; quasi tutti possono essere risolti seguendo questo articolo della KB.

Registri

Server NetWorker:

Il registro delle azioni di backup non fornisce dettagli completi sugli errori di backup delle VM e segnala solo che l'azione ha avuto esito negativo. Verrà visualizzato lo stato dei backup delle VM non riusciti. Controllare i registri dei criteri sul server NetWorker; sarà disponibile un registro delle sessioni contenente il nome della VM:

Linux: /nsr/logs/policy/POLICY-NAME/WORKFLOW-NAME/####-VM-NAME-DATE.log
Windows: C:\Program Files\EMC NetWorker\nsr\policy\POLICY-NAME\WORKFLOW-NAME\####-VM-NAME-DATE.log

Nota: Questi registri di sessione sono le stesse informazioni disponibili nei log vbackupd dell'appliance vProxy e verificano la presenza di eventuali messaggi riguardanti la creazione di snapshot non riuscite.
 

Appliance vProxy:

Accedere all'appliance vProxy utilizzato dal backup della VM utilizzando l'account admin su SSH.

Una volta completato/non riuscito un backup della VM, il registro delle sessioni viene spostato nel seguente percorso:
/opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/

Nota: questi sono gli stessi registri di sessione disponibili sul server NetWorker, come accennato in precedenza.

Il vProxy dispone anche di un log snapmngr che si trova in:
/opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-snapmgr.log

Nota: Questo registro contiene messaggi relativi alla creazione, al consolidamento e all'eliminazione di snapshot.

Cause

All'inizio di un backup di una VM, l'appliance vProxy invia una richiesta di istantanea al vCenter Server. Il vCenter Server è responsabile della creazione e della gestione delle snapshot; eventuali errori osservati si verificano all'interno di VMware e vengono segnalati a NetWorker solo dall'API VMware.

Per una panoramica delle istantanee delle VM, consultare l'articolo della KB di VMware: https://kb.vmware.com/s/article/1015180  image.png

Resolution

Se le snapshot VMware hanno esito negativo durante un'operazione di backup delle VM, è necessario controllare anche la funzionalità delle snapshot VMware dal web client vSphere. Ciò conferma che il problema si verifica all'esterno del flusso di lavoro di backup di NetWorker e all'interno dell'ambiente VMware.

Se il backup della VM è un backup standard basato su immagini, non è necessaria una snapshot inattiva. Se la VM è una VM SQL che esegue backup coerenti con le app MSVMAPPAGENT, è necessario eseguire una snapshot inattiva.

Se la snapshot viene creata correttamente, consolidare la VM ed eliminarla da VMware vSphere.
image.png

È inoltre possibile eseguire Storage vMotion sulla VM per pulire i file della VM.

Eventuali problemi osservati durante la creazione, il consolidamento o l'eliminazione di snapshot devono essere generati al supporto VMware. 

L'utilità ProxyHC può anche essere utilizzata per eseguire una pulizia di potenziali problemi relativi a snapshot/disco se vengono utilizzate le seguenti opzioni: Pulizia disco

attività ./ProxyHCNVP-vProxy: Come utilizzare lo strumento di controllo dell'integrità ProxyHC sull'appliance vProxy

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000201426
Article Type: Solution
Last Modified: 29 Feb 2024
Version:  8
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