Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

NVP-vProxy. Поиск и устранение проблем со снимками VMware во время резервного копирования NetWorker.

Summary: Эта статья базы знаний предназначена для справки службы поддержки NetWorker и администраторов относительно резервного копирования виртуальных машин, которое выполняется с помощью устройства NVP vProxy. Резервное копирование виртуальных машин завершается сбоем с ошибкой, связанной со снимками. ...

This article applies to   This article does not apply to 

Symptoms

  • Виртуальные машины VMware защищены с помощью устройства NetWorker VMware Protection (NVP) vProxy.
  • Сбой резервного копирования с ошибкой, связанной с моментальными снимками. Существует несколько вариантов ошибок моментальных снимков. почти все вопросы можно решить, следуя этой статье базы знаний.

Журналы.

Сервер NetWorker:

В журнале действий резервного копирования не будут представлены подробные сведения о сбоях резервного копирования виртуальной машины, а будет только сообщение о сбое действия. В нем будет отображаться сообщение о сбое резервного копирования ВМ. Проверьте журналы политики на сервере NetWorker, в котором будет журнал сеанса с именем ВМ:

Linux: /nsr/logs/policy/POLICY-NAME/WORKFLOW-NAME/###-VM-NAME-DATE.log
Windows: C:\Program Files\EMC NetWorker\nsr\policy\POLICY-NAME\WORKFLOW-NAME\###-VM-NAME-DATE.log

Примечание. Эти журналы сессий — это та же информация, которую можно найти в журналах vBackupd устройства vProxy. Проверьте наличие любого сообщения о сбое создания моментального снимка.
 

Устройство vProxy:

Получите доступ к устройству vProxy, используемое резервной копией виртуальной машины, с помощью учетной записи администратора по протоколу SSH.

После завершения или сбоя резервного копирования виртуальной машины журнал сессии перемещается в следующее местоположение:
/opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/

Note: это те же журналы сеансов, которые можно найти на сервере NetWorker, как указано выше.

VProxy также имеет журнал snapmngr, который можно найти в:
/opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-snapmgr.log

Примечание. В этом журнале содержатся сообщения о создании, консолидации и удалении снимков.

Cause

В начале резервного копирования ВМ устройство vProxy отправляет запрос на создание снимка на сервер vCenter. Сервер vCenter отвечает за создание и администрирование моментальных снимков. все выявленные сбои в VMware сообщаются в NetWorker только из программного интерфейса (API) VMware.

Обзор моментальных снимков виртуальных машин см. в статье базы знаний VMware: https://kb.vmware.com/s/article/1015180  image.png

Resolution

Если во время операции резервного копирования ВМ происходит сбой моментальных снимков VMware, необходимо также проверить функциональность моментальных снимков VMware из веб-клиента vSphere. Это подтверждает, что проблема возникает за пределами рабочего процесса резервного копирования NetWorker и в среде VMware.

Если резервное копирование ВМ представляет собой стандартную резервную копию на основе образа, создание снимка в пассивном режиме не требуется. Если ВМ является виртуальной машиной SQL, которая выполняет согласованное резервное копирование приложений MSVMAPPAGENT, необходимо выполнить снимок в пассивном режиме.

Если снимок создан успешно, консолидировать виртуальную машину и удалить снимок виртуальной машины из VMware vSphere.
image.png

Для очистки файлов виртуальной машины также можно выполнить Storage vMotion на виртуальной машине.

Все проблемы, наблюдаемые при создании, консолидации или удалении снимков, должны быть вызваны в службу поддержки VMware. 

Утилиту ProxyHC также можно использовать для выполнения очистки потенциальных проблем, связанных с моментальным снимком/диском, если используются следующие параметры: Задача ./ProxyHC очистка диска

NVP-vProxy: Как использовать средство диагностики системы ProxyHC на устройстве vProxy

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000201426
Article Type: Solution
Last Modified: 29 Feb 2024
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.