Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

PowerStore: A secondary storage network cannot be deleted

Summary: Removing a second storage network is not possible from the PowerStore Manager user interface (UI) if the storage network is in use.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A user configured a new storage network (for example, a second storage network for replication).
The option for removing or deleting that network is unavailable in PowerStore Manager:
image.png


Possible errors and messages:

  • PowerStore MAnager: hover over message shows: The selected network is in use and cannot be deleted.
  • PSTCLI: Network XYZ could not be deleted since it is mapped to IP ports: IP_PORT1, IP_PORT2. Unmap all ports from the network before deleting it (0xE0E200702003).
  • PSTCLI: The IP port IP_PORTx cannot be removed from the use by Storage network because it is used for External Replication (0xE0E250701005).

Cause

The network cannot be removed if it is in use (tagged for replication or mapped to any ports).

Resolution

In order to delete or remove a second storage network, you must:
  • Move the replication tag to any other existing storage network:
    • PowerStore Manager > Hardware > APPLIANCES > Click your appliance > PORTS tab > select the new storage network to tag for replication > MORE ACTIONS > Tag for Replication
 
  • Remove the storage network from all network ports. ATTENTION: Only do this if you are sure that nothing is using this network.
    • PowerStore Manager > Hardware > APPLIANCES > Click your appliance > PORTS tab > select the new storage network to tag for replication > MORE ACTIONS > Remove Mapping
 
  • Remove global discovery IP (GDIP) (if there is one set up).
    • Settings > Networking > Network IPs > STORAGE > Select the storage network > MORE ACTIONS > Reconfigure
    • NOTE: Deleting the global discovery IP (GDIP) in PowerStoreOS version 3.5.x.x is not possible. This is resolved in PowerStoreOS version 3.6.0.0 and later.
    • PowerStore CLI (pstcli) is installed on each PowerStore Node, and can be used to delete the network.
    • pstcli -d PowerStoreClusterManagementIP -u admin network show
    • pstcli -d PowerStoreClusterManagementIP -u admin network -name StorageNetworkName delete
 
  • Delete the network.
    • Settings > Networking > Network IPs > STORAGE > Select the storage network > MORE ACTIONS > Delete
 

Additional Information

Remember that a storage network can be used for multiple purposes simultaneously. A few notes from the PowerStore Replication Guide:
When planning for replication using the default configuration, consider that the ports are also used for other traffic like I/O for iSCSI host access, migration, and file (PowerStore T models only). If these features are used, it is recommended to plan replication using dedicated interfaces. Extra ports use dynamic storage IP configuration from the range which was given in the Initial Configuration Wizard (ICW) or added in the networking section of PowerStore Manager.

For more details, see:

Affected Products

PowerStore
Article Properties
Article Number: 000191976
Article Type: Solution
Last Modified: 18 Oct 2023
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.