Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

WD19 Dock Error Message When Updating Firmware While Connected to UP2720Q Monitor

Summary: This article provides information about an error message showing during the WD19 series docks firmware update when connected to the Dell UP2720Q monitor.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

 

Dell Dock Station WD19, WD19S, WD19TB, WD19TBS, WD19DC, WD19DCS connected to the Dell UP2720Q Monitor shows an error message “Too many WD19s are attached” during a dock firmware update. The update fails.

 

WD19_Firmware_Update

(Figure 1: Dell Firmware Update Utility)


Back to Top


Cause

 

The Dell UP2720Q Monitor and Salomon USB Hub have the same VID/PID.


Back to Top


Resolution

 

Disconnect the Dell UP2720Q Monitor to update WD19 Dock Firmware.


Back to Top


Article Properties


Affected Product

Dell UP2720Q, Dell Dock WD19, Dell Performance Dock - WD19DC, Dell Performance Dock – WD19DCS, Dell Dock – WD19S, Dell Thunderbolt Dock - WD19TB, Dell Thunderbolt Dock – WD19TBS

Last Published Date

17 Nov 2021

Version

4

Article Type

Solution