Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell KM636 Keyboard Usage and Troubleshooting Guide

Summary: This article describes the main solutions that have been identified and guidance for diagnostic on the most reported failures on wireless keyboards of the KM636 model.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Affected Products:

  • Dell KM636 Keyboard

The solutions provided apply to, but are not limited to, the following failures:

  • Fully non-functional keyboard
  • Some non-functional keys
  • Low battery life
  • Delay in typing
  • Character repeat failure

Cause

Causes vary. Perform the recommended troubleshooting to determine the cause and solution.

Resolution

Table of Contents:

  1. Check that the Power Switch key is in the on position
  2. Check the battery charge level
  3. Firmware Update
  4. Pair (only if the firmware update performed in the previous step did not resolve the fault)
  5. Pairing dell keyboard and universal mouse
  6. Hardware Testing
  7. Testing with another keyboard/system
  8. Wireless Keyboard and Mouse Updates
  9. How to Clean Your Keyboard
  10. Related Articles

Check that the Power Switch key is in the on position:

Dell KM636 power switch

Back To Top


Check the battery charge level:

Back To Top


Firmware Update:

  • Installing the Firmware Update - Follow the steps below to download and install the Wireless Keyboard firmware update:
    1. Select the Dell Wireless Keyboard and Mouse - KM636 from the Dell Support website > Browse All Products > Electronics and Accessories > PC and Tablet Accessories, then download the latest version of the Dell Universal receiver firmware updater from the list available in Drivers & Downloads.
    2. Ensure that only one Dell Universal dongle is connected to the equipment when you are upgrading the firmware. Insert the dongle for the device that you want to upgrade, then press on the .exe file and begin the installation process.
    3. Press the Next button on the InstallShield Wizard screen:
      Press the Next button when InstallShield wizard appears
    4. Accept the license agreement and press Next:
      Accept the license agreement and press Next
    5. Press Install to start the installation process, and do not remove the dongle:
      Press Install to start the installation process
    6. Press Finish when the InstallShield Wizard completes:
      Press Finish when the installation process is complete
    7. Disconnect and reconnect the dongle according to the orientation to complete the installation:
      Follow the on-screen instructions and reconnect the dongle/receiver

After the firmware update, the LEDs should exhibit a new behavior.

The new behavior is:

  • Once num lock, caps lock and scroll lock are pressed, the LED turns on.
  • After five seconds, the LEDs will turn off to save energy.
  • Pressing the keys (Num Lock, Caps Lock and Scroll Lock) disables the function without visual indication.
  • Pressing again restarts the process with the LED on for five seconds.

Back To Top


Pair (only if the firmware update performed in the previous step did not resolve the fault):

Note: Before performing the pairing, ensure that the client does not have Dell Peripheral Manager installed and running. If yes, remove the application before Installing Dell Universal Pairing. Dell Universal Pairing does not work when Dell Peripheral Manager is installed. For more information, check the article Dell Peripheral Manager Usage and Troubleshooting.
  1. Go to the Mice, Keyboards and Wireless Touchpads selection page (wireless mice, keyboards, and touchpads).
  2. Select the keyboard or mouse model that you have.
Note: To find the model of your keyboard or mouse, look at the bottom of the keyboard or mouse, look for the model on the packaging, or reference the documentation that came with your keyboard or mouse.
  1. Tap or click the Driver and downloads tab.
  2. Tap or click Show All.
  3. Look for the Dell Universal Receiver Control Panel.
  4. Tap or download the Dell Universal Receiver Control Panel section.
  5. Tap or click Save or Save File when prompted.
    Note: The file should be downloaded to the default downloads folder, which is probably the Downloads folder.
  6. Go to where the file was saved. Then double-click or tap the file. (The User Account Control window can be displayed; in this case, click Yes.)
  7. Tap or click Continue.
  8. Tap or click OK.
  9. Tap or click Yes and follow the instructions to install the app.

Back To Top


Pairing dell keyboard and universal mouse:

  1. Start the control panel and plug-in of the Universal USB Dell receiver.
  2. When paired devices already have a profile, remove the pairing by clicking the "Remove device" button.
  3. Tap or click Add New Device.
  4. Follow the instructions.
  5. Turn off all devices (keyboards and mouse).
  6. When pairing a mouse, hold down a mouse button and press the power button, hold down the mouse button for three seconds until pairing is complete.
  7. When pairing a keyboard, hold down a key on the keyboard and press the power button, hold down the keyboard key for three seconds until pairing is complete.
  8. Pairing is complete.

Back To Top


Hardware Testing:

  • Run the advanced diagnostic for SupportAssist keyboards:
    1. Click the Troubleshooting tab and later select the option to check a specific hardware:
      Troubleshooting tab in SupportAssist
    2. Select your Keyboard Device:
      Select Your Keyboard
    3. Press the keys on the keyboard and see if they respond:
      Keyboard Interactive Test

If the customer is unable to run SupportAssist, perform tests on the BIOS and ePSA environment and checking if there is a response.

Back To Top


Testing with another keyboard/system:

  • Ensure that the client has another keyboard and mouse available. If yes, connect the other keyboard and mouse to the device and check the functionality. Also test the keyboard with suspected failure on another computer and check the functionality. Do not forget that the receiver should continue to follow the keyboard/mouse in the tests.
Note: Persisting failure follow with dispatch to exchange the KM636 keyboard/mouse kit.

Back To Top


Wireless Keyboard and Mouse Updates:

Dell Technologies recommends that you update your wireless keyboard and mouse drivers, software, or firmware regularly to avoid conflicts or issues. This ensures that you have the most recent functions and features.

Note: Downloading the latest wireless keyboard and mouse driver, software, or firmware can help improve your devices connectivity, stability, and performance.

Dell Wireless Keyboard and Mouse (KM636)

Back To Top


How to clean your keyboard:

  1. Ensure that the computer is turned off.
  2. Disconnect the keyboard from the computer.
  3. When using a wired, wireless, or Bluetooth keyboard, turn the keyboard upside down and shake it gently to remove any loose material.
  4. Use a vacuum cleaner designed for computers, when available.
  5. Use a can of compressed air to remove any additional loose material when available.
    Caution: Do not turn the can on its side or upside down. This causes a freezing liquid to spray out and can damage your keyboard and skin.
  6. Using a Microfiber or terry cloth wipe the keys and frame around the keys.
    Note: When there is a build-up, take a cotton swab, microfiber towel, or terry cloth and dip it in isopropyl alcohol. It should be damp but not wet. Wipe away the build-up and let the isopropyl alcohol evaporate away before using the keyboard again.

Back To Top

Additional Information

Article Properties


Affected Product

Dell Wireless Keyboard and Mouse- KM636 (black)

Last Published Date

16 Jul 2024

Version

10

Article Type

Solution