Перейти к основному содержимому
  • Простое и быстрое размещение заказов
  • Просмотр заказов и отслеживание состояния доставки
  • Создание списка продуктов и доступ к нему

PPDM: Bulut Yerel Bileşeni yükseltilemedi ve bu da yeni yükseltme paketlerinin SupportAssist'ten yüklenmesini veya indirilmesini engelliyor

Сводка: Bulut Yerel yükseltme bileşeninin "Upgrading" (Yükseltiliyor) aşamasında [paketin geneli Installed (Core) aşamasında] takılı kalmasına neden olan bir sorun var. Bu, ürün işlevlerini etkilemez ancak başka bir yükseltme paketinin yüklenmesini (veya SupportAssist'ten indirilmesini) engeller. ...

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

Müşteri, PPDM'yi 19.5.0.5'ten 19.6.0.3'e yükseltti.  Müşteri 19.7.0.7'ye yükseltmeye çalıştığında yükleme seçeneği devre dışı bırakıldı. "BULUT YEREL" bileşeni için 19.6.0.3 yükseltmesinin devam etmekte olduğu gözlemlendi.


image.png


image.png

Başka bir örnek:

image.png

Причина

Dahili bir sorun, Bulut Yerel bileşeninin herhangi bir Kubernetes kümesinin korunup korunmadığından bağımsız olarak doğru yükseltme durumunu bildirememesine neden olmaktadır. 

PPDM tamamen en son sürüme yükseltilir ve herhangi bir Kubernetes kümesi yapılandırılırsa bunlar da güncelleştirilir.  Bu nedenle sorun, yalnızca gelecekteki herhangi bir yükseltme yapma olanağını etkiler.

Разрешение

Aşağıdaki geçici çözümü uygulayın: 
  1. Herhangi bir Kubernetes kümesi korunuyorsa Kubernetes kümelerinden aşağıdaki komutu çalıştırarak pod'ların doğru sürümde olduğunu doğrulayın:
  • kubectl get configmap ppdm-controller-config -n powerprotect -o yaml  
  1. Pod'lar doğru sürümdeyse veya Kubernetes kümesi yoksa Bulut Yerel bileşeninin "UPGRADING" (YÜKSELTİYOR) durumunu SSH oturumu aracılığıyla PPDM'den şu komut dosyasıyla temizleyin: 
  • /data01/brs/uprade/scripts/cancel_upgrade.sh
  1. Soruna neden olan kayıtları temizlemek için düzeltmeyi uygulayın.
  • pre_upgrade_script_fix_app_host.zip dosyasını indirin ve pre_upgrade_script_fix_app_host.sh komut dosyasını ayıklayın.
  • pre_upgrade_script_fix_app_host.sh komut dosyasını PPDM sanal makinesine kopyalayın
  • Aşağıdaki komutları çalıştırın:
  • chmod +x pre_upgrade_script_fix_app_host.sh
  • ./pre_upgrade_script_fix_app_host.sh
  • Çıktı, sorunlu kayıtların silindiğini göstermelidir:
{
"took" : 14,
"timed_out" : false,
"total" : 3,
"deleted" : 3,
"batches" : 1,
"version_conflicts" : 0,
"noops" : 0,
"retries" : {
"bulk" : 0,
"search" : 0
},
"throttled_millis" : 0,
"requests_per_second" : -1.0,
"throttled_until_millis" : 0,
"failures" : [ ]
}
  1. Hâlâ "Installed (Core)" [Yüklü (Çekirdek)] durumunda olan yükseltme paketini silin ve 19.7 yükseltme paketini yükleyin.
  2. Yükseltmeyi çalıştırın.
  3. Yükseltme tamamlanmalı ve paket "Installed" (Yüklü) durumunu bildirmelidir.

Затронутые продукты

PowerProtect Data Manager
Свойства статьи
Номер статьи: 000183127
Тип статьи: Solution
Последнее изменение: 09 Sep 2022
Версия:  8
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.