Network Disconnects on Non-Dell Computers Using Dell Monitor
Summary:The network may disconnect when using non-Dell computers with Dell monitors that are connected to the monitor network connection.
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Many Dell monitors have Ethernet ports so that a laptop can connect to it and use a wired network connection. The monitor may then replace a laptop docking station. A network disconnection issue may occur when connecting non-Dell computers to Dell monitors using the Ethernet connection. The disconnects may most frequently occur during team calls when network bandwidth usage is at its highest. The non-Dell computer disconnects from the network, but the monitor and anything connected to it functions correctly. This resolves itself within a few seconds.
Affected Monitors:
Dell 24 Video Conferencing Monitor - C2422HE
Dell 27 Video Conferencing Monitor - C2722DE
Dell 34 Video Conferencing Curved Monitor - C3422WE
Dell P2422HE
Dell P2423DE
Dell P2722HE
Dell P2723DE
Dell P2723QE
Dell P3222QE
Dell P3223DE
Dell P3223QE
Dell U2421E
Dell U2421HE
Dell U2422HE
Dell U2721DE
Dell U2722DE
Dell U2723QE
Dell U3023E
Dell U3223QE
Dell U3421WE
Dell U3423WE
Dell U4323QE
Cause
Dell monitors are compatible with non-Dell computers. There are there are three possible causes of this issue:
The Realtek LAN driver used may be an older version or a version that has micro sleeps enabled. There is an issue with older Realtek driver versions and newer versions that are not from the Dell support website causing micro sleeps.
The BIOS setting of the non-Dell computer may have allocated insufficient bandwidth to support a LAN connection and peripheral devices. There is a setting in an HP BIOS called Enable High Speed mode. When this is enabled, the USB lanes on USB-C are limited to USB 2.0.
Usage of USB hubs or indirect connectivity.
Resolution
Realtek LAN driver resolution:
If a Realtek LAN driver is installed on the computer, it must be a minimum version of 10.56. This version and later contain the fixes for microsleep.
If possible, turn off or disable automatic LAN driver updates on the non-Dell computer. Windows Update or the non-Dell manufacturer may update the LAN driver to one that is incompatible.
Non-Dell BIOS settings resolution:
Check the non-Dell computer BIOS settings to ensure that data priority is selected on the device in non-daisy chain applications. Selecting display priority in the BIOS may allocate insufficient bandwidth for LAN and other USB peripherals.
Note:
If using an HP computer, ensure that the BIOS setting for "Enable High Resolution mode when connected to a USB-C DP alt mode dock" is Disabled or unchecked. Disabled or unchecked should mean that the computer is using High Data.
For more information about how to select data priority BIOS settings on your non-Dell computer, reference the computer manufacturer’s user guides.
USB hub resolution:
Directly connect Ethernet and USB devices to the monitor’s Ethernet and USB ports. Do not use USB hubs or dongles attached to the monitor.
Dell monitor resolution:
From the Dell monitor, open the on-screen display menu and check the state of USB-C Prioritization. Ensure that it is set to High Speed Data.
Note: For more information about where to find the USB-C Prioritization setting, reference the user guide for your Dell monitor from the Dell Support Site.