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TL2000 / TL4000 : How to collect the tape library and drive diagnostic logs "DumpAll" for troubleshooting

Summary: This article explains how to generate the troubleshooting log for a PowerVault TL2000 or TL4000 using the graphical interface for recent firmware revision or using the Telnet protocol for older revisions. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 

SLN249113_en_US__1icon Note: This article is part of the Dell PowerVault knowledge library, available here.

This article explains how to generate the troubleshooting log for a PowerVault TL2000 or TL4000 using the graphical interface for recent firmware revision or using the Telnet protocol for older revisions.

  1. Graphical Method
  2. Telnet Method
 
NOTE:  For information on using ITDT-SE please refer to this article: ITDT-SE CLI for Windows – Customer use of ITDT to update Tape Drives and Run Diagnostics.

For information on how to reset the password please refer to this article: How to reset the password on a TL2000 or TL4000
 

Graphical method

Open an Internet page and connect to the tape library web interface (RMU).
Select the Admin account in the drop-down menu.
The default username and password are:
 

User ID: Admin
Password: secure

1. Collect Tape Library Logs
Click on the symbol "+" located next to Service Library (1) to deploy the menu.

Click on Save Library Dump (2).
Click then on Save Service Dump (3).


SLN249113_en_US__2dumpall 1(1)


A pop-up message asking you for the record of the file DumpAllTrace.trc will appear.
 

2. Collect Tape Drive Logs

Click on Save Drive Dump from the Service Library (1) menu.
Select the tape drive to analyze (3).
Click on Save Drive Dump (4).

SLN249113_en_US__3dumpall drive


A pop-up message will appear to inform you that the creation of the file will take time. Drive_Dump.bin will be generated.
The drive operation can be made again on the other tape drives if necessary.

DumpAllTrace.trc and Drive_Dump.bin can be sent to Dell Technical Support for troubleshooting. 

Cause

Telnet Method


If the previous option is not available for some reason, you can telnet into the TL2000 or TL4000 and retrieve the service dump files.
 
In version 6.60 and subsequent versions of the TL2000/TL4000 firmware, you must first enable telnet by selecting "Enable Telnet Port" from the "Service" menu on the front panel of the unit.
The Telnet port cannot be enabled from the web interface, and is disabled by default in firmware revisions from 6.60 forward.
 

 

SLN249113_en_US__1icon Note: Power cycling or rebooting the library resets the telnet port to disabled, so you will have to repeat this process after each power cycle or reboot.

 

 
Once the telnet port is enabled, you can use the Microsoft Telnet Client. The syntax to follow is:

C:\>telnet -f dumpall.txt <IP address>



where <IP address> is the IP address of the TL.
The -f option saves the output of the telnet command to a specified file: in this case, dumpall.txt.

If your telnet session is successful, you should see the following:

FLMON>


At this point, you can type "login". The system will prompt for User Name and Password, the default credentials are Admin / secure. Once logged you should see:

login ok
FLMON>


You can type "dumpAll" and the TL will execute the command, which dumps the internal logs from the unit.
After the command finishes, you can then type "logout" to exit the TL and close the telnet session.

The dumpall log will be saved in the file specified on the command line.

Resolution

-

Videos


Affected Products

Servers, PowerVault TL2000, PowerVault TL4000
Article Properties
Article Number: 000139718
Article Type: Solution
Last Modified: 06 Dec 2021
Version:  7
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