Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

Dell Optimizer 戴尔智能调优软件双电池问题

Summary: 有关 Dell Optimizer 戴尔智能调优软件在 Rugged Latitude 5430、7230 和 7330 上使用双电池时出现多个问题的信息。

This article applies to   This article does not apply to 

Symptoms

使用 Dell Optimizer 戴尔智能调优软件版本 4.0.111.0 和双电池时,可能会出现以下三个问题(图 1):
Rugged Latitude 底部,双电池插槽
图 1:双电池示例

  1. About My Battery”(关于我的电池)将缺失(图2):
    Dell Optimizer 戴尔智能调优软件,关于我的电池
    图 2:Dell Optimizer 戴尔智能调优软件,关于我的电池
     
    电池放置   “关于我的电池”存在  
    插槽 1 + 插槽 2 是 — 对于插槽 2 电池
    仅插槽 1 否 — 缺少功能
    仅插槽 2 是 – 对于插槽 2 电池
  2. 电源功能“高级充电”和“充电模式 — 自适应、主要是交流电源和自定义”缺失(图 3)(仅影响 Latitude 7230 Rugged Extreme 平板电脑):
    缺少 Dell Optimizer 戴尔智能调优软件充电模式
    图 3:缺少 Dell Optimizer 戴尔智能调优软件充电模式
     
    电池和插槽   高级充电存在   充电模式存在  
    插槽 1 中的电池 1 存在的所有模式
    插槽 1 中的电池 2 存在的所有模式
    插槽 2 中的电池 1 仅限标准和快速充电
    插槽 2 中的电池 2 仅限标准和快速充电
    两个电池 仅限标准和快速充电
  3. 动态充电策略”和“充电模式”选项呈灰色显示(图 4 和 5)。此行为有两种情况。
    1. 场景 1 — 在 BIOS 中将电池 1 的充电模式设置为“自定义”。
      然后,“动态充电策略”被禁用并呈灰色显示,没有工具提示“启用自定义充电模式时不支持动态充电策略”,但“充电模式”显示为“Standard”(电池 2 的所选充电模式)(图 4)。
      Dell Optimizer 戴尔智能调优软件,动态策略灰显(不带工具提示)
      图 4:Dell Optimizer 戴尔智能调优软件,动态策略灰显(不带工具提示)
    2. 场景 2 — 在 BIOS 中将电池 2 的充电模式设置为“自定义”。
      然后,“动态充电策略”将 开启 并呈灰色显示,但仍显示工具提示“启用自定义充电时不支持动态充电策略”和“充电模式”呈灰色显示,并显示工具提示“Charging Mode is managed by Dynamic Charge Policy”(图 5)。
      Dell Optimizer 戴尔智能调优软件,带有工具提示的动态策略呈灰色显示
      图 5:Dell Optimizer 戴尔智能调优软件,带有工具提示的动态策略呈灰色显示

返回页首

Cause

  1. 缺少“关于我的电池”问题 — Dell Optimizer 戴尔智能调优软件通过枚举电池来检测列出的第一个电池,插槽 2 是 Windows 中列出的第一个电池。
  2. 缺少“高级充电”和“充电模式 — 自适应、主要交流电源和自定义”问题 — BIOS 返回不正确的值。
  3. 灰显“动态充电策略”和“充电模式”问题 — 动态充电策略检查 SMBIOS 上的第一个电池,但充电模式检查 Windows API 中的第一个电池。这两个来源的顺序不同。从 Dell Optimizer 戴尔智能调优软件的角度来说,我们尚未定义多个电池的电池顺序。

返回页首

Resolution

Dell Optimizer 戴尔智能调优软件更新

更新到最新版本的 Dell Optimizer 以解决此问题。

返回页首

Affected Products

Latitude 7230 Rugged Extreme Tablet, Latitude 7330 Rugged Extreme, Latitude 5430 Rugged
Article Properties
Article Number: 000210226
Article Type: Solution
Last Modified: 27 Feb 2023
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.