Symptoms
The NetWorker Management Console (NMC) Database backup is failing with the following error:
74920:save: Step (4 of 6) for PID-10128: Contacting the NetWorker server through the nsrd process to obtain a handle to the target media device through the nsrmmd process for the save set 'C:\Program Files\EMC NetWorker\Management\nmcdb_stage\pgdata'.
174908:save: Saving the backup data in the pool 'backup_pool'.
175297:save: Unable to set up the direct save with server 'networker_server': no matching devices for save of client `nmc_server'; check storage nodes, devices or pools.
Cause
The error indicates that it is detecting no matching devices for save of client NMC_Server. The "NMC server backup" workflow has a default client override option of "Client can override". This means that the backup will try to send data to the pool set in the client (if set) and not in the pool configured in the workflow.
Resolution
- Confirm if "client can override" is selected (default) in the "Server Protection\NMC server backup" workflow.
- If "client can override" is enabled in the workflow, open the client properties of the NMC server client.
Note: View->Diagnostic Mode must be enabled in the NMC in order to see pool settings in the client properties
- If a pool is set in the client, ensure that this pool has a device that is mounted and the storage node for this device is ready .
- If the pool is incorrect, you can leave the field blank so that the pool configured in the workflow is used OR select the correct pool. To match consistency with other workflows it is recommended to use the workflow pool settings by leaving the client properties "pool" field blank.
Affected Products
NetWorker
Products
NetWorker, NetWorker Management Console