OpenManage Enterprise Console and Plugins window shows NO COMPATIBLE VERSIONS AVAILABLE message
Summary:After the release of OpenManage Enterprise version 4.0, the Console and Plugins windows shows a message 'NO COMPATIBLE VERSIONS AVAILABLE' for plugins that are not installed.
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The following message is seen for plugins that are not installed when reviewing the Console and Plugins window under Application Settings:
NO COMPATIBLE VERSIONS AVAILABLE
Cause
With the release of OpenManage Enterprise version 4.0, all plugins were refreshed to newer versions. The online update catalog for OpenManage Enterprise Plugins points the console to the latest builds. Since these are only compatible with OpenManage Enterprise version 4.0, the 'NO COMPATIBLE VERSIONS AVAILABLE' message is displayed for any plug-in that is not installed.
Resolution
Starting with OpenManage Enterprise version 4.1 the online catalog displays supported plugins when running up to an N-2 version of the appliance. The notification does not have any functional impact to the appliance or plugins that are installed.
For previous versions of OpenManage Enterprise, consider the following scenarios to determine the next steps:
Scenario 1 - Migrate to OpenManage Enterprise 4.0
To run the latest versions of the plugins, first migrate from OpenManage Enterprise version 3.10.x to the latest version 4.0.
NOTE: If running version 3.9.x or earlier, first upgrade OpenManage Enterprise to version 3.10.2 before migrating to version 4.0
See the OpenManage Enterprise User's Guide available on Dell Support for information about performing the appliance migration, Chapter about Backup, Restore, and Migrate.
OpenManage Enterprise 4.0 Appliance Download available from the Drivers and Download page of Dell Support.
Scenario 2 - Continue using a previous version of OpenManage Enterprise
Configure the update path within the Update Settings under Application Settings - Consoles and Plugins within the web UI to install a compatible plug-in.
When logged into the web UI, go to Application Settings > Consoles and Plugins.
Click the Update Settings link.
For the Where to check for updates setting, select the Network Share radio button.
Enter the plug-in's installation path URL from one of the tables below for the Local Path based on the version of OpenManage Enterprise.
NOTE: Only one path can be used at a time when using the Dell online update repository. If an internal share is required, see the OpenManage Enterprise User's Guide, Chapter about Updating the Console and Plugins.
Test the connection to ensure that there are not connection errors.
Click Apply, and then select Yes to save the setting.
Wait a few moments while the console checks for an available plug-in to install.