Перейти к основному содержимому
  • Простое и быстрое размещение заказов
  • Просмотр заказов и отслеживание состояния доставки
  • Создание списка продуктов и доступ к нему

PPDM:Cloud Nativeコンポーネントのアップグレードに失敗し、新しいアップグレード パッケージをSupportAssistからアップロードまたはダウンロードできない

Сводка: Cloud Nativeアップグレード コンポーネントが「Upgrading」(パッケージ全体が「Installed (Core)」)でスタックする問題があります。これは製品の機能には影響しませんが、別のアップグレード パッケージのアップロード(またはSupportAssistからのダウンロード)を妨げます。

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

お客様がPPDMを19.5.0.5から19.6.0.3にアップグレードし、  19.7.0.7にアップグレードしようとすると、アップロード オプションがグレー表示されました。「Cloud Native」の19.6.0.3へのアップグレードがまだ進行中であることが確認されました。


image.png


image.png

別の例:

image.png

Причина

内部の問題により、Kubernetesクラスターが保護されているかどうかに関係なく、Cloud Nativeコンポーネントが正しいアップグレード ステータスを報告できません。 

PPDMは完全に最新バージョンにアップグレードされ、Kubernetesクラスターが構成されている場合は、それらも同様にアップデートされます。  この問題は単純に、今後のアップグレードを実行する機能に影響します。

Разрешение

次の回避策に従います。 
  1. Kubernetesクラスターが保護されている場合は、Kubernetesクラスターから次のコマンドを実行して、ポッドが正しいバージョンであることを確認します。
  • kubectl get configmap ppdm-controller-config -n powerprotect -o yaml  
  1. ポッドのバージョンが正しい場合、またはKubernetesクラスターがない場合は、sshセッションを使用し、PPDMからスクリプトを使用して、Cloud Nativeコンポーネントの「UPGRADING」状態をクリアします。 
  • /data01/brs/uprade/scripts/cancel_upgrade.sh
  1. 修正を適用して、問題の原因となっているレコードをクリアします。
  • pre_upgrade_script_fix_app_host.zipファイルをダウンロードし、pre_upgrade_script_fix_app_host.shスクリプトを解凍します。
  • pre_upgrade_script_fix_app_host.shスクリプトをPPDM VMにコピーします。
  • 以下のコマンドを実行します。
  • chmod +x pre_upgrade_script_fix_app_host.sh
  • ./pre_upgrade_script_fix_app_host.sh
  • 出力には、問題のあるレコードが削除されたと表示されるはずです。
{
  "took" : 14,
  "timed_out" : false,
  "total" : 3,
  "deleted" : 3,
  "batches" : 1,
  "version_conflicts" : 0,
  "noops" : 0,
  "retries" : {
    "bulk" : 0,
    "search" : 0
  },
  "throttled_millis" : 0,
  "requests_per_second" : -1.0,
  "throttled_until_millis" : 0,
  "failures" : [ ]
}
  1. まだ「Installed (Core)」状態のアップグレード パッケージを削除し、19.7アップグレード パッケージをアップロードします。
  2. アップグレードを実行します。
  3. アップグレードが完了し、パッケージは「Installed」状態と報告するはずです。

Затронутые продукты

PowerProtect Data Manager
Свойства статьи
Номер статьи: 000183127
Тип статьи: Solution
Последнее изменение: 09 Sep 2022
Версия:  8
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.