Перейти к основному содержимому
  • Простое и быстрое размещение заказов
  • Просмотр заказов и отслеживание состояния доставки
  • Создание списка продуктов и доступ к нему

PPDM: Cloud Native Component가 업그레이드에 실패하여 SupportAssist에서 새 업그레이드 패키지를 업로드하거나 다운로드할 수 없음

Сводка: Cloud Native 업그레이드 구성 요소가 "Upgrading(전체 패키지는 "Installed (Core)" 상태)"에 멈춰 있는 문제가 있습니다. 이는 제품 기능에 영향을 주지 않지만, 다른 업그레이드 패키지가 업로드(또는 SupportAssist에서 다운로드)되지 않게 됩니다.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

고객이 PPDM을 19.5.0.5에서 19.6.0.3으로 업그레이드했습니다.  고객이 19.7.0.7로 업그레이드하려고 할 때 업로드 옵션이 회색으로 표시됩니다. "CLOUND NATIVE"에 대한 19.6.0.3 업그레이드가 여전히 진행 중임이 관찰되었습니다.


image.png


image.png

다른 예:

image.png

Причина

Kubernetes 클러스터가 보호되고 있는지와 관계없이 내부 문제로 인해 Cloud Native 구성 요소가 올바른 업그레이드 상태를 보고하지 못합니다. 

PPDM은 최신 버전으로 완전히 업그레이드되었으며 Kubernetes 클러스터가 구성된 경우 이 또한 업데이트됩니다.  따라서 이 문제는 향후 업그레이드를 수행하는 기능에 전적으로 영향을 미칩니다.

Разрешение

아래 해결 방법을 따릅니다. 
  1. Kubernetes 클러스터가 보호되고 있는 경우 Kubernetes 클러스터에서 다음 명령을 실행하여 POD가 올바른 버전인지 확인합니다.
  • kubectl get configmap ppdm-controller-config -n powerprotect -o yaml  
  1. POD가 올바른 버전이거나 Kubernetes 클러스터가 없는 경우 ssh 세션을 사용하여 PPDM의 스크립트로 Cloud Native 구성 요소의 "UPGRADING" 상태를 지웁니다. 
  • /data01/brs/uprade/scripts/cancel_upgrade.sh
  1. 수정 사항을 적용하여 문제를 유발하는 레코드를 지웁니다.
  • pre_upgrade_script_fix_app_host.zip 파일을 다운로드하고 pre_upgrade_script_fix_app_host.sh 스크립트를 추출합니다.
  • pre_upgrade_script_fix_app_host.sh 스크립트를 PPDM VM에 복사합니다
  • 다음 명령을 실행합니다.
  • chmod +x pre_upgrade_script_fix_app_host.sh
  • ./pre_upgrade_script_fix_app_host.sh
  • 출력에는 문제가 있는 레코드가 삭제되었음이 나타납니다.
{
  "took" : 14,
  "timed_out" : false,
  "total" : 3,
  "deleted" : 3,
  "batches" : 1,
  "version_conflicts" : 0,
  "noops" : 0,
  "retries" : {
    "bulk" : 0,
    "search" : 0
  },
  "throttled_millis" : 0,
  "requests_per_second" : -1.0,
  "throttled_until_millis" : 0,
  "failures" : [ ]
}
  1. "Installed (Core)" 상태의 업그레이드 패키지를 삭제하고 19.7 업그레이드 패키지를 업로드합니다.
  2. 업그레이드를 실행합니다.
  3. 업그레이드가 완료되고 패키지가 "Installed" 상태를 보고합니다.

Затронутые продукты

PowerProtect Data Manager
Свойства статьи
Номер статьи: 000183127
Тип статьи: Solution
Последнее изменение: 09 Sep 2022
Версия:  8
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.