Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Dell VxRail:VxRail 主機連續重新啟動故障排除指南

Summary: 本文概述在循序重新啟動前檢查步驟和重新啟動步驟中常見的失敗原因,並提供解決問題的建議動作。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VxRail 7.0.480 推出主機順序重新啟動功能。

顯示主機順序重新啟動功能的畫面

重新啟動開始前,會執行預先檢查。其設計目的為防止潛在的故障。
如果在重新啟動期間遇到錯誤,主機將會略過,且程式會繼續至下一個主機。

如果在預先檢查或重新啟動期間報告任何問題,請遵循本文來解決問題。

Cause

各種錯誤都可能導致預先檢查或重新啟動失敗,請參閱本文以下內容以瞭解詳細數據。

Resolution

預先檢查步驟中的潛在錯誤和建議動作。

錯誤訊息 建議的動作
DRS 未完全啟用。 讓 DRS 自動化層級「完全自動化」。請確定您已在 vCenter 中安裝必要的 vSphere 授權。  DRS 功能是該功能的最低需求。
可在此主機上使用 vGPU 執行 VM。 請參閱 VxRail:將主機置於維護模式以解決問題時,具有 vGPU 的虛擬機會失敗遷移
排定時間應少於 7 天。 設定 7 天內排定的重新啟動時間。
主機處於維護模式。 停用所選主機上的維護模式。重新啟動程式會讓主機在重新啟動前進入維護模式。
主機-VM 親和性規則會阻止 VM 遷移至另一個主機。請停用規則或關閉虛擬機。 前往 VxRail 叢集>設定>>組態 VM/主機規則,查看 vCenter 中失敗的主機的 VM-主機親和性規則。  如果有將 VM 限制為單一主機的規則,請與 VM 系統管理員討論。如果您要為該主機使用此功能,請停用規則或關閉虛擬機。
目前叢集的主機數量不得少於 2 (或 3)。 請確定叢集中沒有任何主機處於維護模式。如果有,您可能需要從維護模式退出主機,將使用中的主機數量提高至大於 2 (或 3)。
由於lock_owner已啟動鎖定,<>因此目前無法重新啟動。

另一個 VxRail 作業仍在進行中,無法繼續重新啟動。等待先前的作業完成。

注意:Dell 不建議在兩個部分升級之間執行主機順序重新啟動。若使用者了解風險並想要自行風險執行重新啟動,請聯絡 Dell 技術支援部門尋求協助。

vSAN 叢集未處於良好狀態。 檢閱 vCenter 中 Skyline Health 底下的 vSAN 叢集健全狀況。如需 Skyline 健全狀況故障診斷的進一步詳細數據,請參閱此 VMware 檔。
vSAN 叢集正在重新同步。 前往叢集監視器 vSAN 重新同步物件並檢查詳細數據。執行重新啟動之前,您可能需要等待重新同步完成。
無法使用 vCenter 連線至主機。 檢查主機和 vCenter 之間的連線。如果主機狀態為「未回應」,您必須針對主機和 vCenter 之間的連線問題進行故障診斷。
VM 正在此主機上的非共用數據存放區上執行。 關閉電源、暫停或遷移虛擬機至其他不會重新啟動的主機。或者,將 VM 的儲存裝置遷移到叢集中其他主機可以存取的共用數據存放區。

 

重新啟動步驟中的潛在錯誤和建議動作。

錯誤訊息 建議的動作
無法進入維護模式。 若要檢查進入維護模式失敗的原因,請按下 vSphere 用戶端 > 工作控制台。修正問題並重試進入維護模式。或者,請參閱「如何從 vSAN 觀點檢查 ESXi 維護模式狀態 」,以深入了解維護模式。
主機處於維護模式。 若要將主機從維護模式移除,請按兩下主機,然後選取「Maintenance Mode > Exit Maintenance Mode」。主機結束維護模式後,請在「設定 > VxRail > 主機」頁面上選取「Retry」,然後重新啟動程式會再次執行。
無法開啟主機電源。 這可能是因為主機在重新啟動後開機進入ESXi時發生問題。從 iDRAC 開啟伺服器主控台,查看伺服器開機進入 ESXi 的狀態。
重新啟動已逾時。 單一主機重新啟動逾時設定為20分鐘,如果因為環境問題,重新啟動需要更多時間才能完成,請聯絡 Dell 技術支援以增加逾時值。
Article Properties
Article Number: 000216816
Article Type: Solution
Last Modified: 19 Jan 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.