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Dell VxRail: Troubleshooting guide for VxRail hosts sequential reboot

Summary: This article summarizes common failure reasons during the sequential reboot precheck step and reboot step, and provides suggested actions to address the issues.

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Symptoms

VxRail 7.0.480 introduces host sequential reboot function.

Screen showing host sequential reboot function

Before the reboot begins, there are prechecks that run. These are designed to prevent potential failures.
If an error is encountered during the reboot, the host will be skipped and the process will continue onto the next host.

If any issue is reported during the prechecks or reboots, follow this article to resolve the issues.

Cause

Various errors could cause precheck or reboot failure, refer below on this article for more details.

Resolution

Potential errors and suggested action in Precheck step.

Error Message Suggested Action
DRS is not fully enabled. Enable the DRS Automation Level to "Fully Automated". Ensure you have the required vSphere license to do this installed in your vCenter.  DRS functionality is a minimum requirement for the feature.
Found running VM with vGPU on this host. See VxRail: Virtual Machines with vGPU Fail Migration When Putting Host in Maintenance Mode for resolution.
Scheduled time should be less than 7 days. Set the scheduled reboot time within 7 days.
The host is in maintenance mode. Disable maintenance mode on the selected host. The reboot process puts the host into maintenance mode before the reboot.
The Host-VM affinity rule blocks the VM from migrating to another host. Please either disable the rule or shutdown the VM. Check the VM-Host affinity rules for the failed host in vCenter by going to VxRail Cluster > Configure > Configuration > VM/Host Rules.  If there is a rule restricting that VM to a single host please talk to the VM administrator about it. If you want to use this function for that host either disable the rule or shutdown the VM.
The number of hosts should not be less than 2 (or 3) for the current cluster. Ensure no hosts in the cluster are in maintenance mode. If there are, you may need to exit the host(s) from maintenance mode to raise the number of active hosts to greater than 2 (or 3).
The reboot is currently blocked because the <lock_owner> has initiated a lock.

Another VxRail operation is still in progress that prevents the reboot from continuing. Wait for the previous operation to finish.

Note: Dell does not recommended performing host sequential reboots between two partial upgrades. For users who acknowledge the risk and want to perform the reboot at their own risk, please contact Dell Technical Support for help.

The vSAN cluster is not in a healthy state. Review the vSAN clusters health under Skyline Health in your vCenter. For further details on Skyline Health troubleshooting, see this VMware document.
The vSAN cluster is resyncing. Go to Cluster Monitor vSAN Resyncing Objects and check the details. You may need to wait until resyncing is finished before performing the reboot.
Unable to connect to the host using vCenter. Check the connection between host and the vCenter. If the host status is "not responding" you must troubleshoot the connectivity problem between the host and the vCenter.
VM is running on a non-shared datastore on this host. Power off, suspend or migrate the VM to another host that is not going to be rebooted. Alternatively, migrate the VM's storage to a shared datastore that the other hosts in the cluster can access.

 

Potential errors and suggested action in Reboot step.

Error Message Suggested Action
Failed to enter maintenance mode. To check the failed reason of entering maintenance mode, click vSphere Client > Task Console. Fix the issue and retry entering maintenance mode. Alternatively, see How to Check the ESXi Maintenance Mode Status from the vSAN Perspective to have more detail about maintenance mode.
The host is in maintenance mode. To remove the host from maintenance mode right click the host and select Maintenance Mode > Exit Maintenance Mode. Once the host finishes exiting maintenance mode, select Retry on the Configure > VxRail > Hosts page and the reboot process will run again.
Failed to power on host. This could be because the host has had an issue booting into ESXi after being rebooted. Open the console of the server from the iDRAC to see the status of the servers boot into ESXi.
The reboot reached timeout. A single host reboot timeout is set to 20 minutes, if due to an environmental issue the reboot needs more time to complete, please contact Dell Technical Support to increase the timeout value.