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NVP vProxy registration does not complete with message "HTTP Error 500: Failed to find virtual machine with IP address" and VMware View does not load

Summary: vProxy registration fails with message "HTTP Error 500: Failed to find virtual machine with IP address "vPROXY_IP_ADDRESs" when configuring a new environment for vProxy backups. The NMC VMware View and the new vProxy Wizard show no VMware resources. ...

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Article Content


Symptoms

  • A new NetWorker VMware Protection (NVP) vProxy appliance registration does not complete with error code:
Unable to register NSR VMware proxy 'networker-vproxy.lab.exoduspoint.com': Received an HTTP code: 500, libCURL message: "", vProxy message: "Error received from vProxy ="500: Failed to find virtual machine with IP address "vPROXY_IP_ADDRESS".".  
  • This error is seen in the NetWorker server's /nsr/logs/daemon.raw file and in the NetWorker Management Console (NMC) Alerts window.
  • The new vProxy Wizard does not show any VMware resources.
  • The NMC's VMware View tab does not show anything, even after performing a VMware View Refresh:
NMC's VMware View tab does not show anything
Figure 1: NMC's VMware View tab does not show anything.
 

Cause

The vCenter was added to NetWorker using a customized role. The VMware user is assigned Global Permissions at the vCenter level but Propagate is set to False.

Resolution

  1. Confirm which user account is used to add a vCenter to NetWorker. This is done using nsradmin command on the NetWorker server:
nsradmin
print type: nsr hypervisor


Result of nsradmin command to find user name
Figure 2: Result of nsradmin command to find username
 

NOTE: A VMware administrator or team, or VMware user account with Administrative rights must complete the following actions.
  1. Log in to the vCenter vSphere web client and log in using the administrator@vsphere.local account (or another administrator level account). 
  2. Go to Administration > Access Control > Global Permissions and find the user account from step 1.

Administration > Access Control > Global Permissions > User account from step 1
Figure 3: Administration > Access Control > Global Permissions > User account from step 1

  1. Ensure Propagate checked and identify the Role:

Ensure that Propagate is checked off for the Role
Figure 4: Ensure that Propagate is checked off for the Role.

  1. Go to Administration > Access Control > Roles and ensure that it shows the correct VMware user account with Propagate set to True.

Administration > Access Control > Roles > User account with Propagate set to True
Figure 5: Administration > Access Control > Roles > User account with Propagate set to True


NOTE: This field should only show true. If it has two entries showing "False" and "True," then the issue persists.
 
  1. Return to the NMC and ensure that VMware View loads and is showing VMware resources.

NMC showing that VMware View loads and has VMware resources
Figure 6: NMC showing that VMware View loads and has VMware resources.

  1. If VMware View loads correctly, return to Devices VMware Proxies and register the vProxy.

Article Properties


Affected Product

NetWorker

Product

NetWorker Series

Last Published Date

30 Jun 2023

Version

3

Article Type

Solution