Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Data Domain: FS-proces panic i inode-cachen, når der ikke er mere hukommelse i cacheelementpuljen

Summary: Der er fundet en fejl i nogle nyere DDOS-versioner (bekræftet i 7.7.4, 7.9.0.10 og 7.10.0, som også er dubious, hvis det påvirker DDOS 7.7.3), som kan forårsage panik i FS-processen i inode-cachekoden, når en cache-elementpulje løber tør for hukommelse til yderligere allokeringer afhængigt af arbejdsbyrden. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Der er ingen forringelse eller forhåndsadvarsel for dette problem, som manifesterer sig i form af en FS-procesfejl (PANIC), hvorefter processen genstartes og vises igen korrekt automatisk.
Da kodestien aktiveres, kan FS-processen bryde ned på flere forskellige måder, herunder følgende:
PANIC: ddr/sm/ddfs/ddfs_mtree.c: ddfs_mtree_list: 829: !((dd_errno(e) == ENOENT) || (dd_errno(e) == DD_ERR_FM_EATTRNOENT) || (dd_errno(e) == DD_ERR_STALE))
PANIC: ddr/fv/file_verify.c: file_verify_update_marker_attrs: 4872: Fatal Error
PANIC: ddr/fv/file_verify.c: file_verify_update_snap_attr: 4446: Fatal Error
PANIC: ddr/fv/file_verify.c: file_verify_update_marker_attrs: 4860: Fatal Error
I FS-proceslogfilerne (ddfs.info) vises følgende meddelelser inden hvert procesnedbrud:
01/17 20:21:59.292947 [7fbbf4f98f50] dd_cache_elem_reclaim: Evict count=256, Visited count=257, Skipped elem count=0, Skipped bucket count=0, Time threshold=1539816333626910. (99% full) Complete=True
01/17 20:22:04.662303 [7fbb031ad4f0] ERROR: FM fm_iget:355 - fm_iget failed to allocate elem in dd_cache 5001

Meddelelser, der angiver, at den interne proces var 99 % fuld, kunne derefter ikke allokere yderligere elementer, hvilket fører til procesnedbrud. 

BEMÆRK: Dette problem påvirker kun følgende versioner:
  • DDOS 7.7.3.x: Ikke fuldt bekræftet
  • DDOS 7.7.4.x
  • DD OS 7.9.0.10
  • DDOS 7.10.0.x

Cause

For enhver filhandling som f.eks. læse/skrive er der allokeret en inode-struktur fra dd_cache elementpuljen.
Hvis denne cache er fuld, og der kommer en ny anmodning ind, fjernes et element fra denne cache, og den nye anmodning bliver opfyldt.
Denne udsættelse er baseret på en tidspolitik (et element fjernes, hvis det ikke er blevet åbnet inden for de seneste "x" sekunder).
I tilfælde af, at denne cache bliver for varm (alle elementer er blevet åbnet inden for de seneste "x"-sekunder), og ingen elementer kan fjernes, selv efter flere gentagne forsøg, så fm_iget vender tilbage DD_ERR_NOMEM.
Nogle, der ringer op om denne elementpuljeallokering, vil ikke kunne håndtere fejlen korrekt og får således FS-processen til PANIC, og dump core skal fungere som "fm_iget" returnerer eventuelle fejl. Derfor er der et par forskellige PANIC-signaturer, der svarer til den underliggende kodefejl.

Resolution

Det grundlæggende kodeproblem, der resulterer i disse FS-procesnedbrud, løses ved hjælp af DDOS-168410 i følgende versioner (og alle nyere versioner i de samme kodeforgreninger):
  • DD OS 7.7.5.1
  • DD OS 7.10.1.0
  • DDOS 7.11.0
Kunder, der er påvirket af dette problem, og som ikke kan opgradere til nogen af ovenstående udgivelser med det samme, kan prøve en løsning, de skal kontakte Dell Support for.
Hvis du kører en version med problemet (dem, der er nævnt ovenfor), men du ikke har oplevet et uventet FS-procesnedbrud, men afstemmer symptomerne i dette KB, er det vores anbefaling ikke proaktivt at anvende løsningen og i stedet opgradere til en af de faste versioner ovenfor (eller nogen af deres efterfølgere) for at benytte de seneste opdateringer og koderettelser.

Affected Products

Data Domain
Article Properties
Article Number: 000207919
Article Type: Solution
Last Modified: 21 Dec 2023
Version:  17
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.