Symptoms
When Dell PowerStore encounters an issue, an error alert is generated to help identify the issue. This article explains the different possible causes and the relevant remediation for these error alerts. If your issue is not resolved despite the remediation that is provided, check the technical
support contact options.
Note: Cannot find the information that you need? Let us know using the feedback form at the bottom of this article.
Cause
When NAS server is replicating to a peer system and if there is a communication issue due to management network issues between the two systems, then data access will not be impacted.
However, if the user performs the unplanned failover from the destination then it will bring up the destination NAS server into production mode.
Later when the comminution issue is resolved between source and destination, NAS discovers that both the NAS servers are in production mode and it put the NAS server to maintenance mode to avoid the split-brain which can lead to data corruption.
Resolution
Alert ID |
SDNAS_PEER_VDM_STATUS_PEERVDM_IN_MAINTENANCE |
Alert Text |
NAS server is in maintenance mode for replication session (%(replicationSessionId)). |
Error Code |
0x01303502 |
Impact |
Data protection is impacted. |
Resolution |
Solution: Contact Technical Support for assistance. |
Affected Products
PowerStore