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How to identify faulty part when facing BUS DEVICE FUNCTION error

Summary: This article provides information about identifying malfunctioning devices on PCIe buses in PowerEdge servers, and how to properly troubleshoot these. information about identifying malfunctioning devices on PCIe buses in PowerEdge servers, and how to proper troubleshoot These. The bus device and function point to a particular device on the PCI bus. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Table Of Contents

  1. Error Message
  2. Ways To Determine Bus/Device/Function
  3. Troubleshooting Steps

1. Error Message

Error messages about failed devices can be found in the Server Event Log (SEL) or on the front display (LCD, if given) of PowerEdge servers.
Error codes on the LCD of PowerEdge servers before generation 12:
  • E171f
  • E1711
  • E1712

The bus device and function point to a particular device on the PCI bus. The device can error out for a few reasons. Drivers/Firmware can make a device act erratic like its failing and trigger this message. The obvious other reason would be that the device is malfunctioning. The B# D# F# is the address to the devices location on the PCI bus.


2. Ways To Determine Bus/Device/Function

a. BUS/Device/Function can be found in a XML file in the DSET directory

When a DSET report is created on a system, the file binrawxmlslots.xml can be found in the directory of the created collection.

 

SLN78547_en_US__21306506864560.DSET_slot.xml
Fig. 1: DSET folder

 

Double click on the file for opening it in Internet Explorer or any other browser. Each device is listed by name and under each device name the <BusNum>,<DeviceNum>, and <FunctionNum> are listed.

SLN78547_en_US__31306507113938.DSET_BUSDEVFUNC
Fig. 2: Opened in IE


b. In Windows Device Manager you can check the properties windows

Enter the Windows Device Manager (Windows OS only) and right click on the specific device you want to check. Click on Properties and check the entry under Location on the General tab.

 

SLN78547_en_US__41266947466432.1
Fig. 3: Properties Window


c. Check Registry Entries

The registry location is "Hklm\system\currentcontrolset\enum\PCI\". Each subfolder must be clicked to display the information in the right hand pane.

 

SLN78547_en_US__51266947530527.2
Fig. 4: Registry Editor Window


Cause

The device can error out for a few reasons. Drivers/Firmware can make a device act erratic like its failing and trigger this message. The obvious other reason would be that the device is malfunctioning.

 

Resolution

3. Troubleshooting Steps

After the failed device is indentified, you can start with troubleshooting.

  1. Usually all firmwares of the system should be up to date before starting with next steps. We recommend using a bootable ISO file.
  2. Reseat device (if possible) and restart. The SEL should be deleted before. Otherwise the old error message will be shown again.
  3. Take the device out of the system and restart. The SEL should be deleted before. Otherwise the old error message will be shown again.
  4. Test the device in another slot, if possible.

Affected Products

Servers
Article Properties
Article Number: 000131693
Article Type: Solution
Last Modified: 29 Aug 2023
Version:  7
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