Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Avamar: How to collect Dell System E-Support Tool (DSET) logs from an Avamar Datastore node

Summary: How to collect DSET logs from an Avamar Datastore node.

This article applies to   This article does not apply to 

Symptoms

How to gather DSET logs on Dell Avamar hardware;

1. An Avamar Data store experiences a hardware issue which requires diagnosis by Dell engineers.

2. Avamar Engineering requests the Dell DSET hardware logs to assist with an ongoing engineering escalation.

Cause

Not applicable since we are gathering information to determine a root cause.

Resolution

Run the command dset_script from any directory.

A full DSET report is created in the /tmp/ directory.

dset_script

Example:

dset_script

Dell System E-Support Tool
@Copyright Dell Inc. 2004-2009  Version 1.8 build 130
* Getting Linux system summary information ...
Gathering Network Information ...
Gathering OS Summary Information ...
* Getting Linux operating system configuration information ...
Gathering Boot Information ...
Gathering Module Information ...
Gathering Memory Information ...
Gathering Storage Information ...
Gathering Network Information
Gathering Summary Information ...
Processing Syslog ...

As the script approaches completion you will see the following messages

A compressed, encrypted ZIP report archive was saved at: /tmp/dset_report-on-09-20-2010-at-09-13-AM.zip

Syntax: unzip <reportname> -d <newdirectory>
* Report creation completed successfully
The DSET report is located at /tmp/dset_report*DATE*.zip


 

Additional Information

NOTE:
Occasionally, you see error messages similar to those below.

 

Traceback (most recent call last): File "<string>", line 172, in <module> File "/root/bin/builddellsysteminfo/out1.pyz/dsetcmd", line 91, in Execute File "/root/bin/builddellsysteminfo/out1.pyz/dsetctrl", line 100, in CreateReport File "/root/bin/builddellsysteminfo/out1.pyz/processing.chassis.dsetsmbios", line 41, in GetData File "/root/bin/builddellsysteminfo/out1.pyz/processing.chassis.dsetsmbios", line 117, in __dmidecode File "/root/bin/builddellsysteminfo/out1.pyz/dsetutil.dsetsubprocess", line 133, in Launch File "/root/bin/builddellsysteminfo/out1.pyz/dsetutil.dsetsubprocess", line 252, in __popen4 OSError: The specified binary could not be launched The DSET report is located at /tmp/dset_report*DATE*.zip


In this instance, issue the command as admin with sudo, as below.

admin@avamar:~/test/#: sudo dset_script

To extract logs once uploaded you need the password. The default password for DSET logs is "dell".
 

Affected Products

Avamar

Products

Avamar, Avamar Data Store Gen3, Avamar Data Store Gen4