Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

O backup do NetWorker vProxy falha com "Unable to create non-quiesced snapshot after a retry attempt: Detectou uma configuração de snapshot inválida"

Summary: A integração do NetWorker VMware Protection (NVP) é configurada com o equipamento vProxy. O backup da máquina virtual (VM) de algumas VMs falha com uma mensagem de erro de configuração de snapshot inválida. A exibição de snapshot do vSphere Web Client para a VM não mostra nenhum snapshot disponível para a VM. ...

This article applies to   This article does not apply to 

Symptoms

O registro da sessão de backup mostra:
...
YYYY-MM-DD HH:MM:SS INFO:   [167] Creating snapshot of virtual machine ...
YYYY-MM-DD HH:MM:SS ERROR:  [167] Unable to create non-quiesced snapshot after a retry attempt: Detected an invalid snapshot configuration.
YYYY-MM-DD HH:MM:SS ERROR:  [167] Unable to create snapshot.
YYYY-MM-DD HH:MM:SS INFO:   [167] Enabling storage migration of virtual machine ...
YYYY-MM-DD HH:MM:SS INFO:   [167] Storage migration successfully enabled: "vm-4030" @ "my_vm_name.my_domain.com" 
YYYY-MM-DD HH:MM:SS WARN:   [167] Virtual machine left locked by backup session because cleanup is required.  Snapshot was not removed.
...

O VMNAME_vmware-###.log mostra:
...
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: SNAPSHOT: SnapshotBranchDisk: Failed to branch disk: '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME.vmdk' -> '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-000004.vmdk' : The file already exists (39)
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DiskLib_IsVMFSSparseSupported: vmfssparse is not supported on /vmfs/volumes/DATASTORE_UUID/VM_NAME: f532.
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DISKLIB-LIB_CREATE   : DiskLibCreateCreateParam: Selecting the default child type as SeSparse for /vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-000005.vmdk.
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DISKLIB-LIB_CREATE   : DiskLibCreateCreateParam: seSparse grain size is set to 8 for '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-000005.vmdk'
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: SNAPSHOT: SnapshotBranchDisk failed for '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME.vmdk' : A required file was not found (7).
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DISKLIB-VMFS  : "/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-flat.vmdk" : closed.
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: SNAPSHOT: SnapshotBranch failed: A required file was not found (7).
...

Cause

O problema pode ocorrer quando há arquivos órfãos temporários do descritor de snapshot no diretório de armazenamento de dados da máquina virtual. Esses arquivos descritores de snapshot aparecem como ###.-000001.vmdk, ####.-000001-sesparse.vmdk e ####.-000001-ctk.vmdk.

Resolution

As etapas para remover os arquivos de descritor temporários de snapshot órfãos estão documentadas na base de conhecimento do VMware 80246.

https://kb.vmware.com/s/article/80246 Esse hiperlink direcionará você para um site fora da Dell Technologies.  
  1. Procure o datastore da VM afetada para identificar os arquivos temporários do descritor. O nome pode aparecer como: 
    • ####-000001.vmdk
    • ####-000001-sesparse.vmdk
    • ####-000001-ctk.vmdk 
  2. Identifique uma pasta com espaço suficiente para mover os arquivos de descritor temporários e criar uma nova pasta
    • vmfs/volumes/VM_####_DATASTORE5/FOLDERNAME/
  3. Mover os arquivos de descritor temporários para a pasta recém-criada
  4. Faça o snapshot da VM e validate snapshot criado com sucesso.
  5. Exclua todos os snapshots com a opção "Delete All Snapshots".
  6. Validar a exclusão do snapshot.
  7. Confirme se não há arquivos descritores na pasta do datastore da VM.
  8. Deixe que os backups agendados do vProxy sejam executados.

Additional Information

Affected Products

NetWorker
Article Properties
Article Number: 000196313
Article Type: Solution
Last Modified: 01 Nov 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.