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Avamar: Windows VSS backup fails with "avvss Error 8784", but the backup appears in the Restore UI

Summary: Avamar Windows VSS plug-in backup fails with "avvss Error <8784>: ... Writer 'BITS Writer' instance 'xxxxxxxxxxxx' not found on system!" However, the backup appears in the restore UI and can be restored. All Avamar versions are impacted. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Avamar backups using Microsoft Volume Shadow Copy Service (VSS) for Windows servers are failing: However, the backup shows up on Avamar UI and it is available for restore, but the backup shows up as 'FAILED' in the Activity Monitor.

Error message:

avvss Error <8784>: BackupComplete(): Writer 'BITS Writer' instance '{xxxxxxxx-fc51-43be-a3c5-xxxxxxxx}' not found on system!

avvss Error Example (scrubbed)

Figure 1: Error as seen in the log file

 
 

Cause

The Microsoft Windows BITS Writer on the system is independent of Avamar software.

There are legitimate reasons for the BITS writer to go offline or be missing, such as when Windows Updates have a pending reboot.
The VSS backup logs an error when the BITS writer missing because the Avamar plug-in has a dependency on this writer.
Additional information for the cause of the error can be found in the Event Viewer or Application and System Logs on the affected System.

A code change was introduced into the Avamar Client to resolve this issue.

All current supported Avamar releases include the mentioned code change.

Resolution

The solution differs between Avamar client versions.

Solution for Avamar versions 19.10.100.166:

  • For this version, the issue is permanently fixed, and it does not require any change or flag.
  • Note: If the Avamar Server version is already at version 19.10.1.135, it can be used with client version 19.10.100.166 without the need to upgrade the client catalog.

Solution for Avamar versions 19.10.100.135:

  • Apply the Hotfix 338824 to resolve the issue (no flags are required). 

Solution for Avamar versions 19.9.x:

  • Apply the Hotfix 338789 to resolve the issue (no flags are required). 

For Hotfixes Download instructions see Avamar: How to find and download a product hotfix, patch, install or upgrade package from the Dell Support website

Solution for Avamar versions 19.4,19.7, and 19.8:

  • For these client versions, the code changes must be enabled by using a dedicated "avvss" flag (no hotfix is required).
  • To enable the solution, create an avvss.cmd file in the Avamar var folder, on the client in question, with the following entry:
--ignore_writer_list=4969d978-be47-48b0-b100-f328f07ac1e0
  • The Microsoft defined ID "4969d978-be47-48b0-b100-f328f07ac1e0" uniquely identifies the BITS Writer GUID.
  • The required option can be added to the dataset as well, see below.


Adding the required option to the dataset, example for Avamar User Interface (AUI):

Dataset Options - AUI (scrubbed)

Figure 2: AUI Dataset flag configuration.


Adding the required option to the dataset, example for Graphical User Interface (GUI):

Dataset Options - GUI (scrubbed)

Figure 3: GUI Dataset flag configuration

 

Additional Information

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for Exchange VSS, Avamar Server
Article Properties
Article Number: 000082036
Article Type: Solution
Last Modified: 27 Sept 2024
Version:  12
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