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NetWorker: Backup Fails with Error: 'Save: error no matching devices: check storage nodes, devices or pools'

Summary: A NetWorker backup fails with "no matching devices; check storage nodes, devices or pools"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • A backup operation is performed through NetWorker.
  • The following error message is observed.
    • No matching devices; check storage nodes, devices or pools.

Cause

  • NetWorker Server is not able to resolve the storage node name. This can be due to issues in DNS, or hosts file depending on which it is in use.

 

Resolution

Confirm Name resolution.

1. Run the nslookup command on the NetWorker server to confirm DNS resolution for the NetWorker Storage Node.

nslookup storage_node_name

NOTE: The FQDN, shortname, and IP address should all resolve correctly. DNS resolution issues must be addressed by the domain admin.

2. If DNS is not used, ensure that the NetWorker server's operating system hosts file is updated to include the IP address, FQDN, and shortname of the NetWorker Storage Node.
Linux: /etc/hosts
Windows: C:\Windows\System32\drivers\etc\hosts

Additional Information

This error has other potential causes. If DNS/name resolution is not an issue, see: Troubleshooting No Matching Devices or Media Waiting Errors: https://www.dell.com/support/kbdoc/en-ca/000173177/

 

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000108493
Article Type: Solution
Last Modified: 06 Oct 2022
Version:  3
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