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Latitude 7320, 7420, 5320 and 5420 Fingerprint Reader Is Not Recognized after Being Replaced

Summary: The following article provides information about why the fingerprint reader may not be recognized after being replaced. This is seen on Latitude 7320, 7420, 5320 and 5420 laptops.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Latitude laptop fingerprint reader is not detected after recent replacement

 

Some Latitude 5320, 5420, 7320, and 7420 laptop owners report that their fingerprint reader is not detected.

This happens after the part was replaced on their computer as part of a rework or upgrade.

The fingerprint reader is not detected in the Windows 10 Operating System. (figure.1 English Only)

Fingerprint Reader Not Detected

(Figure.1 Device Manager - Not Detected)


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Cause

The original driver may not recognize the new fingerprint reader. This can occur if the fingerprint reader has been replaced with an identical part, that was manufactured by a different company.


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Resolution

Updating the latest security driver on the computer helps resolve the issue. To download and install the latest fingerprint reader driver, follow the steps that are mentioned below.

WARNING: Downloading and installing Dell-developed drivers or software from third-party or unknown sources can cause the computer or device not to work correctly. They can cause the computer to crash or not boot into the operating system. In some rare instances infect the computer with virus, trojan, or other malicious software.
NOTE: Drivers for third-party or non-Dell products. Such as non-Dell branded printers, docking stations, webcams, scanners, monitors, and so on, must be downloaded from the device manufacturer's website.
  1. Browse to https://www.dell.com/support/drivers.
  2. Identify your Dell computer.
    1. Click Download and Install SupportAssist to auto-detect your Dell computer. Follow the on-screen instructions to install Dell SupportAssist. For more information, see the Dell knowledge base article Dell SupportAssist (formerly Dell System Detect): Overview and Common Questions.
    2. Enter the Service Tag of the laptop and click Search.
    3. Or, click Browse all products and select your Dell computer from the catalog.
  3. Select the Operating System that is installed on the Dell computer.
  4. Under Category, select Security.
  5. Locate the latest Dell ControlVault3 Driver and Firmware.
  6. Click Download and save the file to your computer.
  7. Open File Explorer and browse to the location where the downloaded file is saved.
  8. Double-click the downloaded security driver setup file and follow the on-screen instructions to complete the installation process.

Fingerprint reader detected

(Figure.2 Device Manager - Reader Detected)

If the issue is not resolved by updating the driver, read the following Dell knowledge base article for additional troubleshooting steps:


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Affected Products

Latitude 5320, Latitude 7320, Latitude 7420, Latitude 5420
Article Properties
Article Number: 000185401
Article Type: Solution
Last Modified: 26 Aug 2021
Version:  2
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