Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

Fejlfinding af problemer med DNS- og navnefortolkning

Summary: Fejlfindingsvejledning til problemer med navnefortolkning

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dette er en fejlfindingsvejledning til problemer med navnefortolkning.
 
Problemer omfatter (men er ikke begrænset til):
  • Serveren kunne ikke kommunikere med klienten for at udføre sikkerhedskopieringen.
  • Sikkerhedskopieringen mislykkes med en af følgende fejlmeddelelser:
    • »Kundens navn«: Kunne ikke slå navnet på adressen op:'Backup_server_IP':nodenavn eller tjenestenavn ukendt.
    • Værtsnavn for IP-adresse <IP_address> kunne ikke bestemmes via DNS
    • Advarsel, værtens <værtsnavn> kan ikke fortolkes til <IP-adresse>, navneserveren kan være konfigureret forkert.
    • IP-adressen for værtens "<vært>" kunne ikke bestemmes via DNS.
    • Fejlen "Der opstod timeout for anmodning"
    • Kunne ikke åbne DDBoost-forbindelse til DataDomain-værten "DATA_DOMAIN_FQDN": [5037]
    • Fejl: Kan ikke åbne sessionen til sikkerhedskopieringsstien enhed "DATA_DOMAIN_FQDN": [5037] Ulovlig drift.

Cause

Der er flere årsager. En eller flere af disse årsager kan forekomme:
  • Hardware eller LAN- og WAN-problemer
    • Et netværkskabel et sted i stien er dårligt eller beskadiget eller frakoblet. (CAT5-kabel eller RJ45-stik osv.)
    • Et netværkskort (NIC) fungerer ikke eller understøttes ikke af dit operativsystem. (Driver- eller hardwarefejl)
    • Signalstyrken er ikke god. (kablet eller trådløs dæmpning, tab af intensitet)
  • Problemer med DNS-server (Domain Name System)
  • En computer blev flyttet fra et VLAN til et andet, men beholdt sine gamle indstillinger.
  • Værtsfiler har forkerte poster.
  • Den lokale maskine har gamle DNS-indstillinger i cachen og har ikke opdateret sig selv.
  • Godkendelsesmetoden på både NetWorker-serveren og klienten blev ændret til "oldauth".
  • Indstillinger i firewallen, DNS eller adgangskontrollisten (ACL) er blevet ændret.

Resolution

Før du starter DNS-fejlfinding, skal du udføre nedenstående tre trin:

Hvis der er problemer med disse tre trin, er det et hardware- eller forbindelsesproblem, ikke DNS.
  1. Genstart den maskine, der har problemet. Dette gør det muligt at bringe sig selv tilbage i netværket.
  2. I "Enhedshåndtering" skal du kontrollere driverne og status for netværkshardwaren og -forbindelsen.
  3. Kontroller, at IP-adressen er gyldig i dit lokale netværk. 
Linux:
ifconfig -a
Windows:
ipconfig /all


Du kan finde flere oplysninger om DNS-terminologi og -værktøjer under: DNS – Vilkår og værktøjer

for supportLøsningsfeltet indeholder nogle fejlfindingstrin til operativsystemet. Domæneadministratoren og netværksteamet skal løse eventuelle problemer inden for DNS-strukturen eller netværket. Du kan finde produktspecifik dokumentation i afsnittet Yderligere oplysninger i denne KB.


BEMÆRK: Når du bruger Microsoft Windows "Kommandoprompt", højreklik og vælg "Kør som administrator." For Linux-systemer skal du bruge forhøjede privilegier med sudo eller skifte til root: sudo su - root

Bekræft den DNS-server, der bruges af de involverede systemer:

1. Kør nslookup-forespørgslen mod værterne, der observerer forbindelsesproblemer. Dette skal gøres ved hjælp af det fuldt kvalificerede domænenavn (FQDN), korte navn og IP-adresse. FQDN kan løses korrekt, men flere omvendte opslagsadresser kan returnere flere IP'er for et enkelt værtsnavn, hvilket forårsager problemer. nogle gange fungerer FQDN, men shortname gør det ikke. Alle disse er tegn på et DNS-problem.

nslookup FQDN
nslookup ShortName
nslookup IP_ADDRESS

2. Ovenstående kommandoer returnerer den anvendte DNS-serveradresse. Løs DNS-serveren (FQDN, kort navn, IP-adresse) og ping den. Hvis du bruger flere DNS-servere, skal du pinge hver server. Derefter bruger Ping sin IP-adresse til at kontrollere, om IP'en fungerer, men navnet gør det ikke.  

ping DNS_SERVER_ADDRESS

Ryd DNS-cache 

Sådan skylles DNS-cachen og registreres igen med DNS?

Open a "Command Prompt" right-click and choose "Run As Administrator" or "Root User"
type: IPCONFIG
IPCONFIG /all  - Display full configuration information.
IPCONFIG /release [adapter] - Release the IP address for the specified adapter.
IPCONFIG /renew [adapter] - Renew the IP address for the specified adapter.
IPCONFIG /flushdns  - Purge the DNS Resolver cache.
IPCONFIG /registerdns  - Refresh all DHCP leases and re-register DNS names.
IPCONFIG /displaydns  - Display the contents of the DNS Resolver Cache.
IPCONFIG /showclassid adapter  - Display all the DHCP class IDs allowed for adapter.
IPCONFIG /setclassid adapter [classid]  - Modify the DHCP class id.

På Linux kan flushing af DNS variere afhængigt af Linux-distributionen og pakker, der er installeret på systemet. Se leverandørspecifik dokumentation. 

Kontroller systemets lokale HOSTS-fil

BEMÆRK: De fleste Linux/UNIX-operativsystemer kontrollerer som standard værtsfilen først. Selvom værten kan DNS-løses, bruges en forkert værtsadresse i den lokale værtsfil. Opløsningsprioriteten er defineret i værtslinjen /etc/nsswitch.conf. 
  • For Windows finde: C: \ Windows \ System32 \ drivere \ etc \ værter
  • For Linux skal du finde: /etc/værter
Hvis der er poster for de involverede systemer, skal du sikre dig, at IP-adresserne, værtsnavnene og aliasserne er indtastet korrekt. Ret eller fjern eventuelle forkerte indtastninger. Hvis der er flere poster i en værtsfil for et enkelt system, læses kun den første post. Undgå at bruge flere linjer til at fortolke en adresse til et enkelt system. Du kan løse DNS-problemer ved at oprette værtsfilposter for at fortolke et værtsnavn eller alias for en IP-adresse. 

https://man7.org/linux/man-pages/man5/hosts.5.html Dette hyperlink fører dig til et websted uden for Dell Technologies.

Ping test og routing:

  • Ping to lokale computere i det samme undernet. 
  • Ping to computere i forskellige undernet:  Ping serveren fra klienten og klienten fra serveren osv. Ping ved hjælp af dens "lange navn" og "korte navn" i begge retninger. 
  • Ping ved hjælp af IP-adressen på hver maskine for at kontrollere, om IP fungerer, men Name gør det ikke.
  • En MAC-adresse er en hardwareadresse, der entydigt identificerer hver node i et netværk. Hvert netværkskort har en MAC-adresse. Kontroller, om der er modstridende MAC-adresser, eller om en af MAC-adresserne er blevet sat på en blokeringsliste. Test om muligt forbindelsen med et andet NIC-kort. 
  • Brug en sporingsrutetest til at bekræfte, at dit netværkskort er aktivt, og om DNS fungerer:
Linux:
sudo traceroute TARGET_IP_ADDRESS
Windows: 
tracert TARGET_IP_ADDRESS

DNS-serverindstillinger:

  • FQDN, kort navn og omvendt (IP) opløsning skal fungere. Sådan konfigureres DNS Forward &; Reverse Lookup Zones?
  • Hvis DNS er statisk tildelt (manuelt indtastet på den lokale maskine), skal du kontrollere de korrekte værdier i netværksegenskaberne. Sørg for, at den er inden for det korrekte lokale IP-område uden konflikter. 
    • I Windows skal du klikke på Start, finde Kontrolpanel og derefter klikke på NetværksforbindelserSkift TCP/IP-indstillinger Dette hyperlink fører dig til et websted uden for Dell Technologies.
    • Markér IP-feltet i indstillingerne for netværksforbindelse i operativsystemet. Kontroller, om nogen har indtastet en 'Statisk' IP-adresse, eller indstil den som ikke "Hent automatisk en IP-adresse." Hvis der bruges en "statisk IP" (manuelt indtastet adresse), skal du sikre dig, at det er en gyldig IP i LAN eller VLAN. 
  • På Linux kan konfiguration af IP- og DNS-indstillinger variere afhængigt af Linux-distributionen og de pakker, der er installeret på systemet. Se leverandørspecifik dokumentation. 
  • Hvis DNS tildeles dynamisk af DHCP-serveren (Dynamic Host Configuration Protocol), og der opnås adgang til en vært med et andet navn end dens DNS-værtsnavn, kræves der en DNS-aliaspost. 

Firewall-indstillinger og ACL er:

  • Indstil firewallreglerne til at tillade indgående og udgående TCP-pakker både til og fra tjenesteportene. Indstil intervallet for forbindelsesport og serviceport for en server, klient eller node. For Dell-produkter henvises til de officielle produktvejledninger, der er tilgængelige på Dell Support-NetWorker.  
  • Kontrollér alle lokale netværksindstillinger , som f.eks. ACL (Access Control List), virtuelle lokalnetværk (VLAN er). Er de to maskiner på forskellige VLAN'er eller forskellige netværk, der ikke kommunikerer? Nævn dette ved de forskellige anvendte IP-adresseområder. Din lokale it-gruppe ændrer ACL eller VLANS, hvis det er nødvendigt. Se indstillingerne for porten "Indvendigt" og "Udvendigt" for at kommunikere via en firewall.
  • Port forwarding Når du opretter forbindelse til en port på en gatewaymaskine eller router, videresendes der automatisk til en anden port på en anden maskine. Hvis "Port Mapping" eller "Port Forwarding" er i brug, skal du kontrollere portnumrene, og om de er inden for det påkrævede portinterval. Forkert konfigurerede indstillinger eller ugyldige porte forhindrer forbindelsen.    

Additional Information

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000041288
Article Type: Solution
Last Modified: 25 Mar 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.