Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

Rozwiązywanie problemów z DNS i rozpoznawaniem nazw

Summary: Rozwiązywanie problemów związanych z rozwiązywaniem nazw

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

To jest przewodnik rozwiązywania problemów z rozpoznawaniem nazw.
 
Problemy obejmują między innymi:
  • Serwer nie może skomunikować się z klientem w celu wykonania kopii zapasowej.
  • Tworzenie kopii zapasowej kończy się niepowodzeniem z dowolnym z następujących komunikatów o błędzie:
    • "Nazwa klienta": Nie można wyszukać nazwy adresu:'Backup_server_IP':nazwa węzła lub nazwa usługi nieznana.
    • System DNS nie określa nazwy hosta dla adresu <IP IP_address> nie można ustalić
    • Ostrzeżenie, nie można rozwiązać nazwy hosta>< jako <adresu> IP, serwer nazw może być nieprawidłowo skonfigurowany.
    • Adresu IP "hosta>" hosta< nie można ustalić za pomocą DNS.
    • Błąd "Upłynął limit czasu żądania"
    • Nie udało się otworzyć połączenia DDBoost z hostem "DATA_DOMAIN_FQDN" DataDomain: [5037]
    • Error: Nie można otworzyć sesji do urządzenia ścieżki kopii zapasowej "DATA_DOMAIN_FQDN": [5037] Nielegalna operacja.

Cause

Przyczyn jest wiele. Może istnieć jedna lub więcej z tych przyczyn:
  • Problemy ze sprzętem lub z sieciami LAN i WAN
    • sieciowy znajdujący się gdzieś na ścieżce jest uszkodzony, uszkodzony lub odłączony. (CAT5 lub złącze RJ45 itp.)
    • Karta interfejsu sieciowego (NIC) nie działa lub nie jest obsługiwana przez system operacyjny. (Awaria sterownika lub sprzętu)
    • Siła sygnału nie jest dobra. (utrata natężenia tłumienia przewodowego lub bezprzewodowego)
  • Problemy z serwerem DNS (Domain Name System)
  • Komputer został przeniesiony z jednej sieci VLAN do drugiej, ale zachował stare ustawienia.
  • Pliki hosta zawierają nieprawidłowe wpisy.
  • Komputer lokalny ma stare ustawienia DNS w pamięci podręcznej i sam się nie zaktualizował.
  • Metoda uwierzytelniania na serwerze i kliencie NetWorker została zmieniona na "oldauth".
  • Ustawienia zapory, DNS lub listy kontroli dostępu (ACL) zostały zmienione.

Resolution

Przed rozpoczęciem rozwiązywania problemów z systemem DNS wykonaj trzy poniższe czynności:

Jeśli w tych trzech krokach występują jakiekolwiek problemy, jest to problem ze sprzętem lub połączeniem, a nie z systemem DNS.
  1. Uruchom ponownie komputer, na którym występuje problem. Dzięki temu może powrócić do sieci.
  2. W "Menedżerze urządzeń" sprawdź sterowniki oraz stan sprzętu sieciowego i połączenia.
  3. Sprawdź, czy adres IP w sieci lokalnej jest prawidłowy. 
Linux:
ifconfig -a
Windows:
ipconfig /all


Aby uzyskać dodatkowe informacje na temat terminologii i narzędzi DNS, zobacz: DNS — warunki i narzędzia

pomocy technicznejW polu rozdzielczości znajdują się niektóre czynności rozwiązywania problemów z systemem operacyjnym. Administrator domeny i zespół ds. sieci muszą rozwiązać wszelkie problemy w strukturze lub sieci DNS. Aby uzyskać dokumentację dotyczącą określonego produktu, zapoznaj się z sekcją Informacje dodatkowe w tej bazie wiedzy.


UWAGA: Podczas korzystania z "Wiersza polecenia" systemu Microsoft Windows kliknij prawym przyciskiem myszy i wybierz opcję "Uruchom jako administrator". W przypadku systemów Linux użyj podwyższonych uprawnień za pomocą polecenia sudo lub przełącz się do katalogu głównego: sudo su - root

Potwierdź serwer DNS używany przez systemy, których dotyczy problem:

1. Uruchom zapytanie nslookup dla hostów obserwujących problemy z połączeniem. Należy to zrobić przy użyciu w pełni kwalifikowanej nazwy domeny (FQDN), krótkiej nazwy i adresu IP. Nazwa FQDN może być poprawnie rozpoznawana, ale wiele adresów wyszukiwania wstecznego może zwrócić wiele adresów IP dla jednej nazwy hosta, powodując problemy; czasami nazwa FQDN działa, ale krótka nazwa nie. Wszystko to wskazuje na problem z DNS.

nslookup FQDN
nslookup ShortName
nslookup IP_ADDRESS

2. Powyższe polecenia zwracają używany adres serwera DNS. Rozwiąż problem z serwerem DNS (nazwa FQDN, nazwa skrócona, adres IP) i wykonaj polecenie ping do niego. Jeśli korzystasz z wielu serwerów DNS, wykonaj polecenie ping do każdego serwera. Następnie wykonaj polecenie ping przy użyciu adresu IP, aby sprawdzić, czy adres IP działa, ale nazwa nie.  

ping DNS_SERVER_ADDRESS

Wyczyść pamięć podręczną DNS 

Jak opróżnić pamięć podręczną DNS i ponownie zarejestrować się w DNS?

Open a "Command Prompt" right-click and choose "Run As Administrator" or "Root User"
type: IPCONFIG
IPCONFIG /all  - Display full configuration information.
IPCONFIG /release [adapter] - Release the IP address for the specified adapter.
IPCONFIG /renew [adapter] - Renew the IP address for the specified adapter.
IPCONFIG /flushdns  - Purge the DNS Resolver cache.
IPCONFIG /registerdns  - Refresh all DHCP leases and re-register DNS names.
IPCONFIG /displaydns  - Display the contents of the DNS Resolver Cache.
IPCONFIG /showclassid adapter  - Display all the DHCP class IDs allowed for adapter.
IPCONFIG /setclassid adapter [classid]  - Modify the DHCP class id.

W systemie Linux opróżnianie DNS może się różnić w zależności od dystrybucji Linuksa i pakietów zainstalowanych w systemie. Zapoznaj się z dokumentacją danego dostawcy. 

Sprawdź lokalny plik HOSTS systemu

UWAGA: Większość systemów operacyjnych Linux/UNIX domyślnie najpierw sprawdza plik hosts. Nawet jeśli host jest rozpoznawalny w systemie DNS, używany jest nieprawidłowy adres hosta w lokalnym pliku hosts. Priorytet rozpoznawania jest zdefiniowany w wierszu hostów pliku /etc/nsswitch.conf
  • W przypadku systemu Windows zlokalizuj: C:\Windows\System32\drivers\etc\hosts
  • W przypadku systemu Linux odszukaj: /etc/hosts
Jeśli istnieją jakiekolwiek wpisy dotyczące systemów, których to dotyczy, upewnij się, że adresy IP, nazwy hostów i aliasy zostały wprowadzone poprawnie. Popraw lub usuń wszelkie błędne wpisy. Jeśli w pliku hosts znajduje się wiele wpisów dla jednego systemu, odczytywany jest tylko pierwszy wpis. Nie używaj wielu wierszy do rozpoznania adresu w jednym systemie. Obejście problemów z systemem DNS przez utworzenie wpisów w pliku hosts w celu rozpoznania nazwy hosta lub aliasu na adres IP. 

https://man7.org/linux/man-pages/man5/hosts.5.html Kliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.

Testy ping i routing:

  • Wyślij polecenie ping do dwóch komputerów lokalnych w tej samej podsieci. 
  • Wyślij polecenie ping do dwóch komputerów w różnych podsieciach:  Wysyła polecenie ping do serwera z poziomu klienta, a klienta z serwera, itd. Polecenie ping z użyciem opcji "Długa nazwa" i "Krótka nazwa" w obu kierunkach. 
  • Wykonaj polecenie ping przy użyciu adresu IP każdego komputera, aby sprawdzić, czy adres IP działa, ale nazwa nie.
  • Adres MAC to adres sprzętowy, który jednoznacznie identyfikuje każdy węzeł sieci. Każdy kontroler NIC ma adres MAC. Sprawdź, czy nie ma konfliktów adresów MAC lub czy jeden z adresów MAC nie został umieszczony na liście zablokowanych. Jeśli to możliwe, sprawdź połączenie przy użyciu innej karty sieciowej. 
  • Użyj testu trasy śledzenia, aby sprawdzić, czy karta sieciowa jest aktywna i czy serwer DNS działa:
Linux:
sudo traceroute TARGET_IP_ADDRESS
Windows: 
tracert TARGET_IP_ADDRESS

Ustawienia serwera DNS:

  • Nazwa FQDN, krótka nazwa i rozpoznawanie odwrotne (IP) muszą działać. Jak skonfigurować strefy wyszukiwania DNS do przodu i do tyłu?
  • Jeśli system DNS jest przypisany statycznie (ręcznie wprowadzony na komputerze lokalnym), sprawdź poprawne wartości we właściwościach sieci. Upewnij się, że znajduje się w prawidłowym lokalnym zakresie adresów IP i NIE ma konfliktów. 
    • W systemie Windows kliknij przycisk Start, odszukaj pozycję Panel sterowania, a następnie kliknij pozycję Połączenia sieciowe. Zmiana ustawień TCP/IP Kliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.
    • Zaznacz pole wyboru IP w ustawieniach połączenia sieciowego w systemie operacyjnym. Sprawdź, czy ktoś wprowadził "statyczny" adres IP lub ustaw go jako nie"Automatycznie uzyskaj adres IP". Jeśli używany jest "statyczny adres IP" (adres wprowadzony ręcznie), upewnij się, że jest to prawidłowy adres IP w sieci LAN lub VLAN. 
  • W systemie Linux konfiguracja ustawień IP i DNS może się różnić w zależności od dystrybucji Linuksa i pakietów zainstalowanych w systemie. Zapoznaj się z dokumentacją danego dostawcy. 
  • Jeśli serwer DHCP (Dynamic Host Configuration Protocol) dynamicznie przypisuje serwer DNS, a dostęp do hosta jest używany przy użyciu nazwy innej niż nazwa hosta DNS, wymagany jest rekord aliasu DNS. 

Ustawienia zapory i listy ACL:

  • Ustaw reguły zapory, aby zezwalać na przychodzące i wychodzące pakiety TCP zarówno do, jak i z portów usługi. Ustaw port połączenia i zakres portów usług dla serwera, klienta lub węzła. Informacje na temat produktów firmy Dell można znaleźć w oficjalnych przewodnikach po produktach dostępnych na stronie Dell Support-NetWorker.  
  • Sprawdź wszystkie ustawienia sieci lokalnej , takie jak lista kontroli dostępu (ACL), wirtualne lokalne sieci komputerowe (VLAN). Czy te dwa komputery znajdują się w różnych sieciach VLAN, czy w różnych sieciach, które się nie komunikują? Wspomnij o tym przy użyciu różnych zakresów adresów IP. Lokalna grupa IT modyfikuje listy ACL lub sieci VLAN w razie potrzeby. Zapoznaj się z ustawieniami portów "Wewnątrz" i "Na zewnątrz", aby komunikować się przez zaporę sieciową.
  • Przekierowanie portów Nawiązanie połączenia z portem na maszynie bramy lub routerze powoduje automatyczne przekierowanie do innego portu na innej maszynie. Jeśli używane jest mapowanie portów lub przekierowanie portów, sprawdź numery portów i upewnij się, że port mieści się w wymaganym zakresie. Nieprawidłowo skonfigurowane ustawienia lub nieprawidłowe porty uniemożliwiają nawiązanie połączenia.    

Additional Information

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000041288
Article Type: Solution
Last Modified: 25 Mar 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.