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Solución de problemas de DNS y problemas de resolución de nombres

Summary: Guía de solución de problemas de resolución de nombres

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Esta es una guía de solución de problemas de resolución de nombres.
 
Los problemas incluyen (pero no se limitan a):
  • El servidor no puede comunicarse con el cliente para realizar el respaldo.
  • El respaldo falla con cualquiera de los siguientes mensajes de error:
    • "Nombre del cliente": No se pudo buscar el nombre de address:'Backup_server_IP': nombre del nodo o nombre de servicio desconocidos.
    • El nombre de host para la dirección < IP IP_address> no se pudo determinar a través de DNS
    • Advertencia: no se puede resolver el < nombre >de host a <la dirección> IP; es posible que el servidor de nombres esté configurado erróneamente.
    • La dirección IP para el host '<host>' no se pudo determinar a través de DNS.
    • Error "Se agotó el tiempo de espera de la solicitud"
    • No se pudo abrir la conexión de DDBoost al host "DATA_DOMAIN_FQDN" de Data Domain: [5037]
    • Error: No se puede abrir la sesión en el dispositivo de ruta de respaldo "DATA_DOMAIN_FQDN": [5037] operación ilegal.

Cause

Las causas son múltiples. Es posible que exista una o más de estas causas:
  • Problemas de hardware o de LAN y WAN
    • Un cable de red en algún lugar de la ruta está dañado, dañado o desconectado. (Cable CAT5 o conector RJ45, etc.)
    • Una tarjeta de interfaz de red (NIC) no funciona o no es compatible con el sistema operativo. (Falla del controlador o del hardware)
    • La intensidad de la señal no es buena. (pérdida de intensidad de atenuación con cable o inalámbrico)
  • Problemas del servidor del sistema de nombre de dominio (DNS)
  • Una computadora se movió de una VLAN a otra, pero mantuvo su configuración anterior.
  • Los archivos de host tienen entradas incorrectas.
  • La máquina local tiene una configuración de DNS antigua en la caché y no se ha actualizado.
  • El método de autenticación en el servidor y el cliente de NetWorker se cambió a "oldauth".
  • Se cambió la configuración del firewall, o DNS, o la lista de control de acceso (ACL).

Resolution

Antes de iniciar cualquier solución de problemas de DNS, realice los siguientes tres pasos:

Si hay algún problema con estos tres pasos, entonces es un problema de hardware o conexión, no de DNS.
  1. Reinicie la máquina que presenta el problema. Esto le permite volver a la red.
  2. En "Administrador de dispositivos", compruebe los controladores y el estado del hardware y la conexión de red.
  3. Verifique que la dirección IP sea válida en la red local. 
Linux:
ifconfig -a
Windows:
ipconfig /all


Para obtener información adicional sobre la terminología y las herramientas del DNS, consulte: DNS: términos y herramientas

de soporteEl campo de resolución proporciona algunos pasos para solucionar problemas del sistema operativo. El administrador de dominio y el equipo de red deben resolver cualquier problema dentro de la estructura o la red de DNS. Para obtener documentación específica del producto, consulte la sección Información adicional de esta base de conocimientos.


NOTA: Cuando utilice el "Símbolo del sistema" de Microsoft Windows, haga clic con el botón secundario y seleccione "Ejecutar como administrador". Para los sistemas Linux, utilice privilegios elevados con sudo o cambie a root: sudo su - root

Confirme el servidor DNS utilizado por los sistemas involucrados:

1. Ejecute la consulta nslookup en los hosts que observan problemas de conexión. Esto se debe hacer con el nombre de dominio completo (FQDN), el nombre corto y la dirección IP. El FQDN puede resolverse correctamente, pero varias direcciones de búsqueda inversa pueden devolver varias direcciones IP para un solo nombre de host, lo que causa problemas; a veces el FQDN funciona, pero el nombre corto no. Todo esto es indicativo de un problema de DNS.

nslookup FQDN
nslookup ShortName
nslookup IP_ADDRESS

2. Los comandos anteriores devuelven la dirección del servidor DNS utilizada. Resuelva el servidor DNS (FQDN, nombre corto, dirección IP) y haga ping. Si utiliza varios servidores DNS, haga ping en cada servidor. A continuación, haga ping con su dirección IP para verificar si la IP funciona, pero Name no.  

ping DNS_SERVER_ADDRESS

Borrar caché de DNS 

¿Cómo vaciar la caché de DNS y volver a registrarse con DNS?

Open a "Command Prompt" right-click and choose "Run As Administrator" or "Root User"
type: IPCONFIG
IPCONFIG /all  - Display full configuration information.
IPCONFIG /release [adapter] - Release the IP address for the specified adapter.
IPCONFIG /renew [adapter] - Renew the IP address for the specified adapter.
IPCONFIG /flushdns  - Purge the DNS Resolver cache.
IPCONFIG /registerdns  - Refresh all DHCP leases and re-register DNS names.
IPCONFIG /displaydns  - Display the contents of the DNS Resolver Cache.
IPCONFIG /showclassid adapter  - Display all the DHCP class IDs allowed for adapter.
IPCONFIG /setclassid adapter [classid]  - Modify the DHCP class id.

En Linux, el vaciado del DNS puede variar según la distribución de Linux y los paquetes instalados en el sistema. Consulte la documentación específica del proveedor. 

Compruebe el archivo HOSTS local del sistema

NOTA: La mayoría de los sistemas operativos Linux/UNIX comprueban primero de forma predeterminada el archivo de hosts. Incluso si el host se puede resolver mediante DNS, se utiliza una dirección de host incorrecta en el archivo de hosts locales. La prioridad de resolución se define en la línea hosts del archivo /etc/nsswitch.conf
  • Para Windows, localice: C:\Windows\System32\drivers\etc\hosts
  • Para Linux, localice: /etc/hosts
Si hay entradas para los sistemas involucrados, asegúrese de que las direcciones IP, los nombres de host y los alias se ingresen correctamente. Corrija o elimine las entradas incorrectas. Si hay varias entradas en un archivo de hosts para un solo sistema, solo se lee la primera entrada. Evite usar varias líneas para resolver una dirección en un solo sistema. Solucione los problemas de DNS mediante la creación de entradas de archivo de hosts para resolver un nombre de host o alias para una dirección IP. 

https://man7.org/linux/man-pages/man5/hosts.5.html Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.

Pruebas de ping y enrutamiento:

  • Haga ping a dos equipos locales en la misma subred. 
  • Haga ping en dos computadoras en subredes diferentes:  Haga ping al servidor desde el cliente, y al cliente desde el servidor, y así sucesivamente Ping usando su "Nombre largo" y "Nombre corto" en ambas direcciones. 
  • Haga ping con la dirección IP de cada máquina para verificar si la IP funciona, pero Name no.
  • Una dirección MAC es una dirección de hardware que identifica de manera única a cada nodo de una red. Cada NIC tendría una dirección MAC. Verifique si hay direcciones MAC en conflicto o si una de las direcciones MAC se colocó en una lista de bloqueo. Si es posible, pruebe la conexión con una tarjeta NIC diferente. 
  • Utilice una prueba de ruta de seguimiento para verificar que la NIC esté activa y si el DNS funciona:
Linux:
sudo traceroute TARGET_IP_ADDRESS
Windows: 
tracert TARGET_IP_ADDRESS

Configuración del servidor DNS:

  • El FQDN, el nombre corto y la resolución inversa (IP) deben funcionar. ¿Cómo configurar las zonas de búsqueda directa e inversa de DNS?
  • Si el DNS se asigna de manera estática (ingresado manualmente en la máquina local), verifique los valores correctos en las propiedades de red. Asegúrese de que se encuentre dentro del rango de IP local correcto sin conflictos. 
    • En Windows, haga clic en Inicio, busque el Panel de control y, a continuación, haga clic en Conexionesde redCambiar la configuración de TCP/IP Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.
    • Marque la casilla IP en la configuración de conexión de red en el sistema operativo. Verifique si alguien ingresó una dirección IP "Estática" o configúrela como no "Obtener automáticamente una dirección IP". Si se utiliza una "IP estática" (dirección ingresada manualmente), asegúrese de que sea una IP válida en la LAN o VLAN. 
  • En Linux, la configuración de los ajustes de IP y DNS puede variar según la distribución de Linux y los paquetes instalados en el sistema. Consulte la documentación específica del proveedor. 
  • Si el servidor de Dynamic Host Configuration Protocol (DHCP) asigna dinámicamente DNS y se accede a un host con un nombre distinto de su nombre de host de DNS, se requiere un registro de alias de DNS. 

Configuración de firewall y ACL:

  • Configure las reglas de firewall para permitir paquetes TCP entrantes y salientes hacia y desde los puertos de servicio. Configure el rango de puertos de servicio y puerto de conexión para un servidor, cliente o nodo. En el caso de los productos Dell, consulte las guías oficiales de productos disponibles en Dell Support-NetWorker.  
  • Compruebe cualquier configuración de red local, como la lista de control de acceso (ACL) o las redes de área local virtual (VLAN). ¿Las dos máquinas se encuentran en diferentes VLAN o redes diferentes que no se comunican? Mencione esto mediante los diferentes rangos de direcciones IP utilizados. El grupo de TI local modifica la ACL o las VLAN, si es necesario. Consulte la configuración del puerto "interno" y "externo" para comunicarse a través de un firewall.
  • Reenvío de puertos Cuando se conecta a un puerto en una máquina de gateway o enrutador, se reenvía automáticamente a otro puerto en una máquina diferente. Si se utilizan "Port Mapping" o "Port Forwarding", verifique los números de puerto y si se encuentra dentro del rango de puertos necesario. Los ajustes configurados erróneamente o los puertos no válidos impiden la conexión.    

Additional Information

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000041288
Article Type: Solution
Last Modified: 25 Mar 2025
Version:  8
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