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PowerProtect Data Manager Appliance DM5500: VM Direct Engine is Unable to Backup a Virtual Machine Asset Because of a Protection Storage Issue

Summary: The PPDMA VM backup fails, and only a generic error is found in its logs. The more specific error is found in the storage logs.

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Symptoms

Generic error found in PPDMA logs:

ABV0009: VM Direct engine 'XXXXXXXX' is unable to back up the virtual machine 'XXXXXXXX' on vCenter 'XXXXXXXX' because of a protection storage issue.


Specific error found in Protection Storage logs:

07/25 16:14:01.114614 [7f4f4fce72f0] ERROR: MSG-FM-00060: **** fastcopy(xxxxxx) aborted: Hard Quota Exceeded

Cause

When the MTree has the quota set, there is not a mechanism to return that exact error message to the client (Boost) when the fastcopy fails due to quota exceeded condition. It attempts to process the fastcopy and fails, and then Boost checks if the fastcopy file exists to determine if the operation was successful or not. This is why it cannot return a specific error to the client - there is not a way to return the error code. The change is to check if the fastcopy causes the MTree to exceed the quota before it initiates the command. Thus, returning the error that it fails before it starts the fastcopy operation. This allows Boost to get the exact quota exceeded error code.

Resolution

This is a known issue on PowerProtect Data Manager Appliance DM5500 version 5.12.0.1-206 or earlier. This issue is planned to be addressed in an upcoming release.

Affected Products

PowerProtect DM5500
Article Properties
Article Number: 000205839
Article Type: Solution
Last Modified: 17 May 2023
Version:  4
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