跳转至主要内容
  • 快速、轻松地下订单
  • 查看订单并跟踪您的发货状态
  • 创建并访问您的产品列表

Integrert databeskyttelsesapparat: vSAN-objekt er utilgjengelig etter strømbrudd

摘要: Integrert Data Protection Appliance (IDPA) vSAN-objekt er utilgjengelig etter strømbrudd.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

IDPA-modellene DP5x00 eller DP8x00 med tre ESXi-verter viser at vSAN-objektet er utilgjengelig fra vSphere-grensesnittet og ESXi-kommandolinjen etter gjenoppretting fra strømbrudd. Omstart av de tre ESXi-vertene hjelper heller ikke.

Her er et eksempel:
  • Vis vSAN-tilstandsstatus fra en av ESXi-vertene:
# esxcli vsan health cluster list Health Test Name                                    Status --------------------------------------------------  ------------------------ Overall health                                      red (vSAN Object health) Data                                                red    vSAN object health                               red

Kan ikke vise VM-objekter. Den slår ikke på VM fra vSphere-webgrensesnittet eller kommandolinjen med lignende feil:
# vim-cmd vmsvc/getallvms Skipping invalid VM '41' Skipping invalid VM '43' Skipping invalid VM '44'

Vis vSAN-klyngeinformasjon funnet at vedlikeholdsmodus fortsatt er satt til ON (PÅ) fra én av klyngenodene:
# esxcli vsan cluster get Cluster Information    Enabled: true    Current Local Time: 2021-04-11T00:44:48Z    Local Node UUID: 5afb4fd2-6e89-df35-0ab3-3cfdfe2caa40    Local Node Type: NORMAL    Local Node State: MASTER    Local Node Health State: HEALTHY    Sub-Cluster Master UUID: 5afb4fd2-6e89-df35-0ab3-3cfdfe2caa40    Sub-Cluster Backup UUID: 5afb4f4f-589e-acf6-1c85-3cfdfe2c89e0    Sub-Cluster UUID: 52740a1b-3621-f158-7b09-439048860c07    Sub-Cluster Membership Entry Revision: 2    Sub-Cluster Member Count: 3    Sub-Cluster Member UUIDs: 5afb4fd2-6e89-df35-0ab3-3cfdfe2caa40, 5afb4f4f-589e-acf6-1c85-3cfdfe2c89e0, 5afb4ef8-b1b7-1f4a-f923-3cfdfe2c88a0    Sub-Cluster Membership UUID: 4c137260-c6b9-0aa9-e52b-3cfdfe2caa40    Unicast Mode Enabled: true    Maintenance Mode State: ON    Config Generation: 66541957-e1a1-478b-9a87-106bcf5cb77a 25 2021-03-18T20:31:02.389
   
Fra samme ESXi-vert, når du kjører show system maintenanceMode status, står det at den er deaktivert. Dette er inkonsekvent med kommandoen ovenfor.
# esxcli system maintenanceMode get Disabled 

原因

Dette problemet oppstår når vSAN slår seg av uventet uten å sette verten i vedlikeholdsmodus først. Denne avslutningen kan skyldes en strømbruddhendelse eller en kommandolinjeavslutning eller omstart av ESXi-verter. Det kan føre til utilgjengelighet for vSAN-datalageret.

解决方案

  1. SSH-pålogging til ESXi-verten som viser inkonsekvent vedlikeholdsmodusstatus. Sett verten i vedlikeholdsmodus manuelt, og flytt den ut av vedlikeholdsmodus:
# esxcli system maintenanceMode set --enable=true # esxcli system maintenanceMode set --enable=false
  1. Kontroller vSAN-klyngestatusen på nytt. Du kan forvente at statusen for vedlikeholdsmodus vises som AV, og at VM-ene kan slås på uten feil:
# esxcli vsan cluster get Cluster Information    Enabled: true    Current Local Time: 2021-04-11T00:44:48Z    Local Node UUID: 5afb4fd2-6e89-df35-0ab3-3cfdfe2caa40    Local Node Type: NORMAL    Local Node State: MASTER    Local Node Health State: HEALTHY    Sub-Cluster Master UUID: 5afb4fd2-6e89-df35-0ab3-3cfdfe2caa40    Sub-Cluster Backup UUID: 5afb4f4f-589e-acf6-1c85-3cfdfe2c89e0    Sub-Cluster UUID: 52740a1b-3621-f158-7b09-439048860c07    Sub-Cluster Membership Entry Revision: 2    Sub-Cluster Member Count: 3    Sub-Cluster Member UUIDs: 5afb4fd2-6e89-df35-0ab3-3cfdfe2caa40, 5afb4f4f-589e-acf6-1c85-3cfdfe2c89e0, 5afb4ef8-b1b7-1f4a-f923-3cfdfe2c88a0    Sub-Cluster Membership UUID: 4c137260-c6b9-0aa9-e52b-3cfdfe2caa40    Unicast Mode Enabled: true    Maintenance Mode State: OFF
 

受影响的产品

PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800

产品

PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
文章属性
文章编号: 000185168
文章类型: Solution
上次修改时间: 23 8月 2022
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。