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ESXi 5.x - "Performance has deteriorated. I/O latency increased" messages in the vmkernel logs.

概要: This article provides information on how to identify possible causestroubleshoot "Performance has deteriorated. I/O latency increased" messages in the VMkernel logs.

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

This article provides information on how to identify possible causes\troubleshoot "Performance has deteriorated. I/O latency increased" messages in the VMkernel logs.

  

Environment

  • VMware vSphere 5.x
  • Dell Equallogic PS series arrays

     

Issue

  • VMkernel.log shows messages similar to:
    • Device naa.5000c5000b36354b performance has deteriorated. I/O latency increased from average value of 1832 microseconds to 19403 microsecond

       

Possible causes

  • Some of the possible reasons why the device latency increased are:
    • Changes made on the target
    • Disk or media failures
    • Overload conditions on the device
    • Failover\Load Balancing

       

Steps to identify\troubleshoot the issue

  • Verify if the iSCSI environment is accordance with Equallogic's network configuration requirements and recommendation for high performance and reliability.

  • Verify if the Hosts NICs, Switches and Arrays are at latest drivers\firmware revision.

  • Verify if the ESX hosts have Delayed ACK disabled, and the iSCSI login timeout settings are set to 60 seconds:

    • Telnet\SSH directly to the host IP address and run the following commands and check the results:
      vmkiscsid --dump-db | grep Delayed
      vmkiscsid --dump-db | grep login_timeout

      These values should reflect "0" and "60" respectively.

    • Disable Delayed ACK and change the iSCSI login timeout settings if needed

     

  • In case further troubleshooting is needed, please contact Dell Tech support. The Following logs will be helpful:

    • VMsupport logs from the ESX hosts.

    • Switches Logs

    • SANHQ Archive if available:

      • Start SANHQ and select Monitor

      • On the drop down select create archive.

      • Choose ‘select all groups’ or select a specific group.

      • Once selected, click on ‘create archive’ The file is in *.gprx format

       

     

 


原因

Not Applicable

解決方法

Not Applicable

対象製品

Virtualization Solutions, EqualLogic (PS Series), EqualLogic PS M4110, EqualLogic PS4210 Series, EqualLogic PS4210E, EqualLogic PS4210X, EqualLogic PS4210XS, EqualLogic PS4210XV, EqualLogic PS6210E, EqualLogic PS6210S, EqualLogic PS6210X , EqualLogic PS6210XS, EqualLogic PS6210XV, EqualLogic PS6610E, EqualLogic PS6610ES, EqualLogic PS6610X, VMware ESXi 5.x ...
文書のプロパティ
文書番号: 000179447
文書の種類: Solution
最終更新: 14 3月 2024
バージョン:  9
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