Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
Certains numéros d’article ont peut-être changé. Si ce n’est pas ce que vous recherchez, essayez de faire une recherche sur tous les articles. Rechercher des articles

WD19 Series Dock Firmware Update Fails on Computers with Windows 10 19H1 or Higher

Résumé: This article provides information about the WD19 series dock firmware update failing on systems with Windows 10 19H1 or higher.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

WD19 Series Docking Station Firmware Update Failure

An error may occur while updating WD19 Series dock firmware. "Error: Unable to reboot WD19. Power cycle the dock to complete the update." A red X is displayed next to the EC firmware portion of the update. (Figure 1.) This error may occur updating the firmware on any WD19 or WD19S series dock.

WD19x updated fails

Figure 1. - WD19 Dock Firmware Update Failure

 

Cause

These computers use legacy thunderbolt driver, and BIOS assist thunderbolt firmware. However, later versions of Windows 10 (19H1 or higher) do not support the legacy driver. These versions of Windows 10 require native thunderbolt firmware.

Résolution

Note: The power button on the dock does not power cycle the WD19. The power button emulates the computer power button.

To resolve the firmware update error, complete these troubleshooting steps:

  1. Click Exit in the firmware update utility.
  2. Disconnect the WD19 USB Type-C connector from the computer.
  3. Unplug the AC adapter from the WD19 dock.
  4. Wait 30 seconds.
  5. Reconnect the AC adapter connection to the WD19 dock. (The power button LED should flash three times then go off.)
  6. Reconnect the dock USB Type-C cable connection to the computer.
  7. Rerun the WD19 dock firmware update.
  8. The firmware update now completes without errors.

Informations supplémentaires

Recommended Articles

Here are some recommended articles related to this topic that might be of interest to you.

Produits concernés

Dell Dock WD19, Dell Performance Dock - WD19DC, Dell Performance Dock – WD19DCS, Dell Dock – WD19S, Dell Thunderbolt Dock - WD19TB, Dell Thunderbolt Dock – WD19TBS, Latitude 7280, Latitude 7380, Latitude 7480, Latitude 5580, Precision 7520 , Precision 7720, Latitude 5280 mobile thin client ...
Propriétés de l’article
Numéro d’article: 000184585
Type d’article: Solution
Dernière modification: 24 Sep 2024
Version:  8
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.