Symptômes
Inżynierowie firmy Dell zaobserwowali nieczęsty problem podczas pracy systemu z dyskiem Dell PM1725a Express Flash NVMe PCIe SSD, przez który urządzenie może przechodzić w tryb offline i stawać się niedostępne. Dysk może być ponownie dostępny po ponownym uruchomieniu komputera.
Błędy takie jak "nvme_remove_namespaces", "nvme0n1: wykryto zmianę pojemności z xxxxxxxxx na 0" oraz różne błędy systemu plików mogą być widoczne w dziennikach zdarzeń systemowych /var, /log, /messages lub innych dziennikach zdarzeń systemu. Ponadto dalsze korzystanie z dysku SSD wymagałoby ponownego utworzenia systemu plików. Ten problem został rozwiązany przez poprawkę oprogramowania wewnętrznego.
Cause
Problem jest spowodowany błędem zarządzania pamięcią podręczną. Gdy bufor pamięci podręcznej zapisu jest pełny, kontroler błędnie odrzuca przychodzącą operację WRITE z hosta. Zostało to rozwiązane poprzez obsługę przychodzących operacji WRITE z hosta po wyczyszczeniu zawartości pamięci podręcznej.
Résolution
Problem został rozwiązany w kwietniu 2019 r. przez wydanie oprogramowania wewnętrznego Dell Express Flash NVMe PCIe SSD PM1725a, wersja 1.1.2, A03.
UWAGA: Ponieważ wszystkie wersje oprogramowania wewnętrznego PM1725a przed 1.1.2 są narażone na ten problem, oprogramowanie wewnętrzne inne niż 1.1.2 zostało usunięte z witryny wsparcia technicznego Dell i są już niedostępne do pobrania.
Produits concernés
Storage Spaces Direct R640 Ready Node, Storage Spaces Direct R740xd Ready Node, PowerEdge R640, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R830, PowerEdge R840