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VxRail: Troubleshooting Guide for a VMware ESXi hosts in "Not Responding" State

Resumen: This article provides solutions to issues with virtual machines residing on a not responding ESXi host and helps return the ESXi host to a stable state.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

  • ESXi host reported as "Not Responding" on vSphere Web Client.
  • Unable to manage ESXi hosts from a vSphere Web Client.
  • Able to ping the "Not Responding" ESXi host and the virtual machines on it.
  • Able to access the virtual machines through SSH/RDP running on the ESXi host.

Causa

One of the management services on the host might have failed or gone into a "Not responding" state.

This requires root cause analysis about why the management services failed or stopped responding. Collect the vCenter Server, and the ESXi host logs by referencing Collecting diagnostic information for VMware ESXi This hyperlink is taking you to a website outside of Dell Technologies.before bringing the cluster/ESXi to a stable state. Sometimes it is impossible as the node is not responding to the commands to collect logs. Review the information in the Resolution section of this article. Logs can be analyzed through DELL support if necessary to understand the root cause to check if the below known issues are related to the issue.

Resolución

Restarting hostd or vpxa on the host could help bring back the host manageability on the vSphere Client. This can be done using an SSH session to the ESXi host.
One other response to a "Not Responding" ESXi host is by restarting the Management agents on the ESXi hosts. 

Restarting Management agents of an ESXi host could be done directly using a CLI/SSH session to the ESXi (if SSH is enabled prior to the issue). 
However, if SSH is not enabled, accessing the BMC/iDRAC Port would give access to the ESXi DCUI Screen where the management services can be restarted.
See VMware KB - 1003490 for Restarting the Management agents in ESXi.This hyperlink is taking you to a website outside of Dell Technologies.

The DCUI may become unresponsive. Manual shutdown of the Virtual Machines (VM) using SSH or RDP is the only other option to bring back the environment to a stable state. Once done, using BMC/iDRAC Power Control, Power Cycle (reboot) the ESXi host to get the ESXi host to a stable state.

To reduce the downtime for the virtual machines prior to rebooting the "Not Responding" ESXi host. Register the Virtual Machines to other stable hosts right after shutting down the Virtual Machines. (After which the issue ESXi host can be rebooted)
Here are steps on How to register or add a Virtual Machine (VM) to the vSphere Inventory in vCenter ServerThis hyperlink is taking you to a website outside of Dell Technologies.

If unable to power off the virtual machines using SSH/RDP, terminate a virtual machine through the ESXi host SSH session see Unable to Power off a Virtual Machine in an ESXi hostThis hyperlink is taking you to a website outside of Dell Technologies.


Virtual machine issues: 

Unable to power off the virtual machine in an ESXi host - 1014165This hyperlink is taking you to a website outside of Dell Technologies.

Powering off an unresponsive virtual machine on an ESXi host - 1004340This hyperlink is taking you to a website outside of Dell Technologies.

Virtual machines appear as invalid or orphaned in vCenter Server -  1003742This hyperlink is taking you to a website outside of Dell Technologies.

Virtual machines appear to be running or registered on multiple ESX/ESXi Servers - 1005051This hyperlink is taking you to a website outside of Dell Technologies.

Powering on a virtual machine from the command line when the host cannot be managed using vSphere Client - 1038043This hyperlink is taking you to a website outside of Dell Technologies.

Troubleshooting a virtual machine that has stopped responding - 1007819This hyperlink is taking you to a website outside of Dell Technologies.

Virtual machine file related issues: 

Rebuilding the virtual machine's .vmx file from vmware.log - 1023880This hyperlink is taking you to a website outside of Dell Technologies.

Investigating virtual machine file locks on ESXi - 10051This hyperlink is taking you to a website outside of Dell Technologies.

Verifying ESX/ESXi virtual machine file integrity - 1003743This hyperlink is taking you to a website outside of Dell Technologies.

Productos afectados

VxRail, VxRail Appliance Family, VxRail Appliance Series, VxRail Software
Propiedades del artículo
Número del artículo: 000191728
Tipo de artículo: Solution
Última modificación: 22 nov. 2024
Versión:  4
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