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How to Reset the Integrated Dell Remote Access Controller (iDRAC)

Resumen: This article explains multiple methods to reset the Integrated Dell Remote Access Controller (iDRAC) both locally and remotely including reset, reset to defaults and reset to customer configuration. ...

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

The Integrated Dell Remote Access Controller (iDRAC) is responsible for system profile settings and out-of-band management. Sometimes, iDRAC may become unresponsive due to various reasons. Symptoms of an unresponsive iDRAC include the following:

  • RACADM commands return "ERROR: Unable to perform requested operation"
  • No SSH/Telnet access to the iDRAC (the attempted connection times out)
  • No iDRAC browser access
  • Pinging the iDRAC IP address fails

Causa

The iDRAC may become unresponsive due to various reasons. Dell Technologies recommends keeping your system up to date with the latest iDRAC firmware available. This ensures the best performance and the latest security updates and fixes. iDRAC updates do not require a reboot of the host, allowing for in-place updates. The iDRAC firmware version for a server model may vary from other server models with an iDRAC. To download the latest iDRAC firmware for your system:

  1. Go to the Dell Support site and then select the server model or enter the service tag.
  2. Select the Drivers & Downloads tab.
  3. Select the iDRAC with Lifecycle Controller category.
  4. Optionally, select the Operating system for your system.
  5. Download the latest version provided for iDRAC with Lifecycle Controller firmware.
Updating Firmware and Drivers on Dell PowerEdge Servers provides a listing of the multiple methods to update the iDRAC firmware.

Resolución

iDRACs can be reset by using the System Identification Button, the iDRAC Web Interface, the iDRAC Service Module, or RACADM. Click the appropriate section for more information.

System Identification Button

For systems with an iDRAC, a small button that is marked "i" (Figure 1 and Figure 2) is typically on the front and back of the system. This i button is the System Identification button. In order to reset the iDRAC without rebooting the operating system, press and hold the System Identification button for at least 16 seconds. Stop pressing the button when the cooling fans start spinning at full speed and the front LCD (if present) is off. Now the iDRAC restarts without changing any saved settings. It may take a minute or longer until the remote controller restarts.

iDRAC i button on PowerEdge R640 server
Figure 1: iDRAC i button on PowerEdge R640 server

iDRAC i button on PowerEdge T620 server
Figure 2: iDRAC i button on PowerEdge T620 server

iDRAC Web Interface

Resets are performed differently for the iDRAC9 Web Interface and the iDRAC7 and iDRAC8 Web Interface. Click the appropriate iDRAC for more information.

iDRAC9 Web Interface

  1. Connect to the iDRAC Web interface.
  2. Log in to the interface by entering the username and password.
  3. Click the Maintenance tab.
  4. Select Diagnostics.
  5. Click Reset iDRAC to reset the iDRAC or click Reboot iDRAC to reset the iDRAC.
Note: The reset button available in your environment may differ due to the iDRAC firmware version.

Reset iDRAC button in iDRAC9
Figure 3: Reset iDRAC button in iDRAC9

Reboot iDRAC button
Figure 4: Reboot iDRAC button

  1. Alternately, click Reset iDRAC to Default Settings to reset the iDRAC to the default settings. After clicking the Reset iDRAC to Default Setting, Reset iDRAC to factory default window is displayed. This action resets the iDRAC to factory defaults. Choose any of the following options:
    • Preserve user and network settings.
    • Discard all settings and reset the users to shipping value (root/shipping value).
    • Discard all settings and reset username and password.
    • Discard all settings and set to Custom default configuration (Custom configuration file must be uploaded).
  2. A warning message is displayed. Click Ok to proceed.
Note: It is also possible to input iDRAC command lines directly from this screen.

iDRAC7 and iDRAC8 Web Interface

  1. Connect to the iDRAC Web interface.
  2. Log in to the interface by entering the username and password.
  3. In the lower right corner of the overview screen, the Quick Launch Tasks are shown.
  4. Click Reset iDRAC.
  5. Confirm the action.

Reset iDRAC option for iDRAC7 and iDRAC8
Figure 5: Reset iDRAC option for iDRAC7 and iDRAC8

How to Reset the Integrated Dell Remote Access Controller (iDRAC)

Duration: 00:01:24 (hh:mm:ss)
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iDRAC Service Module

The iDRAC Service Module (iSM) is a lightweight software application that can be installed on PowerEdge servers running iDRAC7, iDRAC8 and iDRAC9. iSM 2.3 (and newer) allows the administrator to reset the iDRAC remotely when iDRAC is unresponsive. Resetting the iDRAC using the iDRAC Service Module is performed differently whether using Windows, Linux, or VMware ESXi Operating Systems. Click on the appropriate operating system for more information.

Windows

iDRAC Service Module provides the WMI Method, PowerShell Method, and the Program Menu Shortcut Method through which the iDRAC can be reset from within a Windows operating system. Click the appropriate method for more information.

WMI Method

This can be invoked either locally or remotely using Windows Management Instrumentation (WMI) commands.

To reset the iDRAC using WMI commands, the procedure is as follows:

  1. Install the iDRAC Service Module on the host operating system.
  2. Open Command Prompt with administrator rights.
  3. Run either the local WinRM command or the remote WinRM command.
    • Local WinRM command: winrm i iDRACHardReset wmi/root/cimv2/dcim/DCIM_iSMService?InstanceID="iSMExportedFunctions"
    • Run the remote WinRM command: winrm i iDRACHardReset wmi/root/cimv2/dcim/dcim_ismservice -u:"admin-username" -p:"password" -r:http://"remote-hostname or IP"/wsman -a:Basic -encoding:utf-8 -skipCACheck -skipCNCheck
Note: WinRM server or listener configuration is mandatory for using the above WinRM remote command. For configuration of WinRM as a listener; see Installation and Configuration for Windows Remote Management.
PowerShell Method

This can be invoked either locally or remotely using PowerShell commands.

To reset the iDRAC using local PowerShell commands, the procedure is as follows:

Prerequisites

  • Requires Microsoft .NET Framework 64-bit version 2.x or newer.
  • The execution policy for running PowerShell scripts should be set to one of the following:
    • Set-ExecutionPolicy AllSigned
    • Set-ExecutionPolicy Unrestricted

iDRAC Service Module also provides a PowerShell cmdlet to locally reset the iDRAC. To use PowerShell for resetting the iDRAC:

  1. Open a Windows PowerShell session as an administrator.
  2. Type Invoke-iDRACHardReset and then press Enter.
Note: The -force option can be used to reset the iDRAC through a script or without the confirmation message.

To use the Invoke-iDRACHardReset command from a remote PowerShell session:

Note: The prerequisite for PS-Remoting is WinRM configuration as a listener.
  1. Launch a PowerShell session on the management station.
  2. Enable remote PowerShell using the Enable PS-Remoting cmdlet.
Program Menu Shortcut Method

This can be run by logging into the operating system using a remote desktop session. Then, select the iDRAC reset option from the program menu.

Linux

On all iSM-supported Linux operating systems, the iSM provides commands which can be run by logging into the operating system by using SSH or equivalent.

The commands are either:

  • $ /opt/dell/srvadmin/iSM/bin/Invoke-iDRACHardReset
  • $ /opt/dell/srvadmin/iSM/bin/Invoke-iDRACHardReset -f
Note: There is an option to specify the force (-f) option along with the command. This does not wait for user confirmation and proceeds with the iDRAC reset action.

VMware ESXi operating systems

On all iDRAC Service Module supported ESXi operating systems; iSM 2.3 and newer supports a CMPI method provider. This enables performing the iDRAC reset remotely using WinRM remote commands. Unlike Windows (except WMI) and Linux operating systems; ESXi does not prompt the user for a confirmation before resetting the iDRAC.

The command is:

  • winrm i iDRACHardReset http://schemas.dell.com/wbem/wscim/1/cim-schema/2/root/cimv2/dcim/DCIM_iSMService?__cimnamespace=root/cimv2/dcim+InstanceID=iSMExportedFunctions -u:"root-username" -p:"password" -r:https://"Host-IP":443/wsman -a:basic -encoding:utf-8 -skipCNCheck -skipCACheck -skipRevocationcheck

The result of the operation is displayed as an integer value which indicates either success or failure of the operation.

Limitations:

On ESXi 6.0 U1 and ESXi 6.0 U2 versions of ESXi; the IPMI driver may become unresponsive after the iDRAC reset. After a Hard Reset operation on certain VMware ESXi operating systems, the IPMI driver (ipmi_si_drv) may become unresponsive because of an existing issue in the IPMI driver. If the IPMI driver becomes unresponsive, reload the IPMI driver (ipmi_si_drv).

To reload the ipmi_si_drv:

  1. /etc/init.d/sfcbd-watchdog stop
    esxcfg-module -u ipmi_si_drv => unload ipmi_si_drv
    esxcfg-module ipmi_si_drv => load ipmi_si_drv
    /etc/init.d/sfcbd-watchdog start
Note: Alternatively, the administrator can also restart the host operating system to resolve the issue.

RACADM

The Dell Remote Access Controller Admin (RACADM) utility is a command-line tool that allows for remote or local management using the iDRAC. RACADM commands can be run remotely from a management station or locally on the managed system.

In all instances, only the iDRAC reboots and this does not reboot the server. An iDRAC reboot does not affect the running operating system. There are differences in the commands between the iDRAC9 and the iDRAC7 or iDRAC8. Click the appropriate iDRAC for more information.

iDRAC9

Reset - This reboots the iDRAC without changing any iDRAC configuration settings.
Example: racadm racreset

Reset (forced) - Adding -f to any iDRAC command forces the command.
Example: racadm racreset -f

Reset iDRAC to factory defaults - this resets all changes back to factory settings, but keeps user and network settings.
Example: racadm racresetcfg

Reset iDRAC configuration to default and reset user to shipping value.
Example: racadm racresetcfg -all

Reset iDRAC configuration to default and reset the user to a username of root and password of calvin.
Example: racadm racresetcfg -rc

Reset iDRAC configuration to custom defaults.
Example: racadm racrsetcfg -custom

All iDRAC9 reset commands can be found in the Integrated Dell Remote Access Controller 9 (iDRAC9) Version 3.00.00.00 User's Guide | Dell US (page 249).

iDRAC7 or iDRAC8

Reset - This reboots the iDRAC without changing any iDRAC configuration settings.
Example: racadm racreset

Adding -f to any iDRAC command forces the command.
Example: racadm racreset -f

Reset iDRAC to factory defaults - this resets all changes back to factory settings. This removes user and network settings.
Example: racadm racresetcfg

All iDRAC7 or iDRAC8 reset commands can be found in the iDRAC 8/7 v2.81.81.81 RACADM CLI Guide (page 105).

Productos afectados

iDRAC7, iDRAC8, iDRAC9, PowerEdge XR2, PowerEdge C4130, Poweredge C4140, PowerEdge c6320, PowerEdge c6320p, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, Poweredge FC430, Poweredge FC630, PowerEdge FC640 , Poweredge FC830, PowerEdge FD332, PowerEdge FM120x4 (for PE FX2/FX2s), PowerEdge FX2/FX2s, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M420, PowerEdge M520, PowerEdge M520 (for PE VRTX), PowerEdge M620, PowerEdge M620 (for PE VRTX), PowerEdge M630, PowerEdge M630 (for PE VRTX), PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge M820, PowerEdge M820 (for PE VRTX), PowerEdge M830, PowerEdge M830 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R220, PowerEdge R230, PowerEdge R240, PowerEdge R250, PowerEdge R320, PowerEdge R330, PowerEdge R340, PowerEdge R350, PowerEdge R420, PowerEdge R420XR, PowerEdge R430, PowerEdge R440, PowerEdge R450, PowerEdge R520, PowerEdge R530, PowerEdge R530xd, PowerEdge R540, PowerEdge R550, PowerEdge R620, PowerEdge R630, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R720, PowerEdge R720XD, PowerEdge R730, PowerEdge R730xd, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R820, PowerEdge R830, PowerEdge R840, PowerEdge R860, PowerEdge R920, PowerEdge R930, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T130, PowerEdge T140, PowerEdge T150, PowerEdge T320, PowerEdge T330, PowerEdge T340, PowerEdge T350, PowerEdge T420, PowerEdge T430, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T620, PowerEdge T630, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9680, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR7620, PowerEdge XR8610t, PowerEdge XR8620t ...

Productos

iDRAC Service Module
Propiedades del artículo
Número de artículo: 000126703
Tipo de artículo: Solution
Última modificación: 21 sept 2023
Versión:  17
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