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PowerVault ME4: After Drive Firmware Upgrade, Samsung SSDs Fail with "Illegal Request, logical block address out of range"

Summary: It is possible to mistakenly flash specific Samsung SSD models on DSA3 firmware with firmware DWA3 that is meant for other Samsung drive models. This may result in data unavailability. Resolving this requires flashing the drive firmware with the original DSA3 version for the drive model. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Samsung Solid-State Drives (SSDs) may be marked as failed shortly after a drive firmware upgrade from DSA3 to DWA3.
  • The Samsung drive models description, capacity, and firmware versions are reported incorrectly. ​​​
  • One of more Samsung SSD drives may be in a failed state.
  • One or more disk groups may be offline in quarantine state.
  • The ME4 event log reports the following SCSI sense data: 0x5,0x21,0x0,0x2100, "Illegal Request, logical block address out of range."
A4929      2022-04-18 21:43:05  58    INFORMATIONAL  An event was reported by a disk drive. (disk: channel: 0, ID: 8, SN: S5YLNE0N501919, enclosure: 0, slot: 8) (Key,Code,Qual,UEC:0x5,0x21,0x0,0x2100) (CDB:Rd 5d26ce80 0080)(Info:0x5D26CEB0)(CmdSpc:0x0, FRU:0x0, SnsKeySpc:0x400007)(Illegal Request, logical block address out of range)
 

Cause

Samsung firmware version DWA3 applies to the following Dell drive models:
  • MZILT800HBHQ0D3
  • MZILT1T6HBJR0D3

Samsung firmware version DSA3 applies to the following Dell drive models:
  • MZILT960HBHQ0D3
  • MZILT1T9HBJR0D3
  • MZILT3T8HBLS0D3
  • MZILT7T6HALA0D3

 

NOTE: When upgrading drive firmware on PowerVault ME series arrays, review the readme.txt file that is contained within the drive firmware .zip download to match the available firmware version to the drive model in the PowerVault ME array.
See Dell KB article: ME4: A disk firmware update is available for your system

The drive model and Dell part number are also shown on the physical drive label. Do not remove drives while the system is turned on unless the drive is marked as failed or offline. If you must view the drive label to confirm the original model while the drive is offline, it is best to shut down the array following the administrator's guide or online help.
 

 

Physical drive label

 

 
 

Resolution

Do not pull, replace drives, or turn off the PowerVault ME array.

If drives are marked in failed state or disk groups are offline in quarantine state, contact Dell technical support for assistance.

To expedite resolution, collect or send a support bundle from the PowerVault ME for analysis by Dell technical support. See the following articles for instructions:


The drives can be flashed with the original DSA3 firmware however, further actions may be required to restore the system to production.

 

NOTE: Updated firmware DAS4 or DWA4 is available for these Samsung SSD drive models that is not included in Dell PowerVault ME Series Storage HDD/SSD Firmware package. To prevent application of the incorrect firmware, administrators must contact Dell technical support to obtain the drive update package. Refer the agent to KB 000207843. 

Affected Products

ME Series, Dell EMC PowerVault ME4012, Dell EMC PowerVault ME4024, Dell EMC PowerVault ME4084, Dell EMC PowerVault ME412 Expansion, Dell EMC PowerVault ME424 Expansion, Dell EMC PowerVault ME484, PowerVault ME5012, PowerVault ME5024 , PowerVault ME5084 ...
Article Properties
Article Number: 000199115
Article Type: Solution
Last Modified: 09 Jun 2023
Version:  5
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