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Thunderbolt Device Has Yellow Bang in Device Manager

Summary: When a Thunderbolt device (dock or hard drive) is plugged in to a USB-C port, the device has a yellow bang in device manager.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Platforms:

  • Latitude Laptop
  • Precision Mobile
  • Dell Thunderbolt Dock - WD22TB4

Affected Products:

  • Dell Thunderbolt Dock - WD22TB4

Certain so-called USB4 device in the market may not be correctly detected on Dell laptops. The issue occurs when connecting the device to either the USB4 port on the laptop directly, or the USB4 port on the WD22TB4 dock. The issue is present when Disabled USB4 PCIE Tunneling is set to On, or Thunderbolt Technology Support is Disabled. The issue was noticed with ORICO-MTQ-40G SSD, but can be seen with other devices.

After plugging-in a Thunderbolt device into a USB-C port, the device shows a yellow bang in device manager like the figure below:

Yellow bang on Thunderbolt 3 Device Router (Microsoft)

Cause

Windows 11 PCIe driver cannot configure a Thunderbolt controller.

Resolution

To resolve, follow these steps:

  1. Enter BIOS.
  2. Set Disable USB4 PCIE Tunneling to OFF.
    Disable USB4 PCIE Tunnelling
    Note: The factory default setting is OFF.
  3. Set Thunderbolt Technology Support to Enabled to support more USB or thunderbolt devices.

Affected Products

Dell Pro 13 Premium PA13250, Latitude 5330, Latitude 7330, Latitude 9330, Latitude 5431, Latitude 7430, Latitude 9430, Latitude 5530, Latitude 7530, Latitude 5430, Precision 3570, Dell Thunderbolt Dock – WD22TB4
Article Properties
Article Number: 000197714
Article Type: Solution
Last Modified: 26 Mar 2025
Version:  12
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