Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Guide de dépannage Dell EMC VxRail pour les hôtes VMware ESXi en état « Not Responding » (Ne répond pas)

Summary: Cet article fournit des solutions aux problèmes liés aux machines virtuelles se trouvant sur un hôte ESXi à l’état « Not Responding » et permet de rétablir l’état stable de l’hôte ESXi. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

  • Hôte ESXi signalé comme « Not Responding » sur vSphere Web Client.
  • Impossible de gérer les hôtes ESXi à partir d’un client Web vSphere.
  • Possibilité d’envoyer un ping à l’hôte ESXi « Ne répond pas » et aux machines virtuelles qui y sont situées.
  • Possibilité d’accéder aux machines virtuelles via SSH/RDP s’exécutant sur l’hôte ESXi.

Cause

L’un des services de gestion sur l’hôte peut avoir échoué ou être passé à l’état

« Not responding ». Cela nécessite une analyse des causes premières sur la raison pour laquelle les services de gestion ont échoué ou ont cessé de répondre. Collectez le serveur vCenter et les logs de l’hôte ESXi en vous reportant à La collecte des informations de diagnostic pour VMware ESXi avant de ramener le cluster/ESXi à un état stable. Cela est parfois impossible, car le nœud ne répond pas aux commandes de collecte des journaux. Consultez les informations de la section Résolution de cet article. Les journaux peuvent être analysés par le support DELL EMC si nécessaire pour comprendre la cause première afin de vérifier si les problèmes connus ci-dessous sont liés au problème.

Resolution

Le redémarrage de hostd ou vpxa sur l’hôte peut vous aider à retrouver la facilité de gestion de l’hôte sur vSphere Client. Cette opération peut être effectuée à l’aide d’une session SSH sur l’hôte ESXi.
Une autre réponse à un hôte ESXi « Ne répond pas » consiste à redémarrer les agents de gestion sur les hôtes ESXi. (Reportez-vous à l’article de la base de connaissances VMware - 1003490)

Le redémarrage de l’agent de gestion d’un hôte ESXi peut être effectué directement à l’aide d’une session CLI/SSH vers ESXi (si SSH est activé avant le problème). 
Toutefois, si SSH n’est pas activé, l’accès au port BMC/iDRAC donne accès à l’écran DCUI ESXi où les services de gestion peuvent être redémarrés.
Reportez-vous à l’article de la base de connaissances VMware: 1003490 pour redémarrer les agents de gestion dans ESXi.

Si l’interface de console DCUI ne répond plus et que vous ne parvenez pas à redémarrer les agents ou les services de gestion, l’arrêt manuel des machines virtuelles (enregistré sur ce nœud mais affiché déconnecté sur vCenter) à l’aide de SSH ou RDP est le seul autre moyen de rétablir les machines virtuelles et l’hôte ESXi à un état stable. Une fois que vous avez terminé, à l’aide du contrôle de l’alimentation BMC/iDRAC, redémarrez l’hôte ESXi pour que l’hôte ESXi soit à l’état stable.

Vous pouvez réduire le temps d’inactivité des machines virtuelles avant de redémarrer l’hôte ESXi « Not Responding ». Enregistrez les machines virtuelles sur d’autres hôtes stables juste après l’arrêt des machines virtuelles. (Après quoi le problème de l’hôte ESXi peut être redémarré).
Voici les étapes à suivre pour enregistrer ou ajouter une machine virtuelle (VM) à l’inventaire vSphere dans vCenter Server.

Si vous ne parvenez pas à mettre les machines virtuelles hors tension à l’aide de SSH/RDP, mettez fin à une machine virtuelle via la session SSH de l’hôte ESXi. Reportez-vous à la section Impossible de mettre hors tension une machine virtuelle sur un hôte ESXi. 


Problèmes de machine virtuelle: 

Impossible de mettre hors tension la machine virtuelle sur un hôte ESXi - 1014165

Mise hors tension d’une machine virtuelle qui ne répond pas sur un hôte ESXi - 1004340

Les machines virtuelles apparaissent comme non valides ou orphelines dans vCenter Server - 1003742

Machines virtuelles semblent être en cours d’exécution ou enregistrées sur plusieurs serveurs ESX/ESXi - 1005051

machine virtuelle en cours d’exécution est inaccessible et contient des fichiers de configuration manquants - 2006648

Les machines virtuelles sont orphelines après le redémarrage de l’hôte ESXi sur lequel elles résident ( 2013301

Mise sous tension d’une machine virtuelle à partir de la ligne de commande lorsque l’hôte ne peut pas être géré à l’aide de vSphere Client - 1038043

Impossible de mettre sous tension une machine virtuelle ESX/ESXi qui fonctionnait précédemment - 1003648

dépannage d’une machine virtuelle qui a cessé de répondre - 1007819

impossible de mettre sous tension une machine virtuelle hébergée - 1003671
 

Problèmes liés au fichier de machine virtuelle: 

Reconstruction du fichier .vmx de la machine virtuelle à partir de vmware.log - 1023880

Procédure d’enquête sur le verrouillage de fichiers de la machine virtuelle sur ESXi - 10051

Vérification de l’intégrité des fichiers de la machine virtuelle ESX/ESXi - 1003743

Article Properties


Affected Product

VxRail, VxRail Appliance Family, VxRail Appliance Series, VxRail Software

Last Published Date

13 Oct 2022

Version

3

Article Type

Solution