Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Feilsøkingsveiledning for Dell EMC VxRail for en VMware ESXi-vert i tilstand som ikke svarer

Summary: Denne artikkelen inneholder løsninger på problemer med virtuelle maskiner som ligger på en ESXi-vert som ikke svarer, og hjelper deg med å gjenopprette ESXi-verten til en stabil tilstand. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

  • ESXi-verten rapporterte at den ikke svarer på vSphere Web Client.
  • Kan ikke administrere ESXi-verter fra en vSphere-webklient.
  • Kan pinge ESXi-verten og de virtuelle maskinene som ikke svarer.
  • Få tilgang til virtuelle maskiner via SSH/RDP som kjører på ESXi-verten.

Cause

En av administrasjonstjenestene på verten kan ha sviktet eller gått inn i tilstanden Not responding (Svarer ikke).

Dette krever analyse av hovedårsaken for hvorfor administrasjonstjenestene mislyktes eller sluttet å svare. Samle inn vCenter Server og ESXi-vertsloggene ved å referere til innsamling av diagnostikkinformasjon for VMware ESXi før du setter klyngen/ESXi til en stabil tilstand. Noen ganger er det umulig siden noden ikke svarer på kommandoene for å samle inn logger. Se gjennom informasjonen i delen Løsning i denne artikkelen. Logger kan analyseres av DELL EMC-støtte om nødvendig for å forstå hovedårsaken til å kontrollere om de kjente problemene nedenfor er relatert til problemet.

Resolution

Omstart av hostd eller vpxa på verten kan bidra til å bringe tilbake vertens administrering på vSphere Client. Dette kan gjøres ved hjelp av en SSH-økt til ESXi-verten.
Ett annet svar på en ESXi-vert som ikke svarer, er ved å starte administrasjonsagentene på ESXi-vertene på nytt. (Se VMware KB – 1003490)

Omstart av administrasjonsagenten til en ESXi-vert kan gjøres direkte ved hjelp av en CLI/SSH-økt til ESXi (hvis SSH er aktivert før problemet). 
Hvis SSH ikke er aktivert, vil tilgang til BMC-/iDRAC-porten gi tilgang til ESXi DCUI-skjermen der administrasjonstjenestene kan startes på nytt.
Se VMware KB – 1003490 for omstart av administrasjonsagentene i ESXi.

Hvis DCUI-konsollgrensesnittet slutter å svare og du ikke kan starte administrasjonsagenter eller -tjenester på nytt, er manuell avslutning av de virtuelle maskinene (registrert på denne noden, men viser frakoblet vCenter) ved hjelp av SSH eller RDP den eneste andre veien rundt for å bringe tilbake de virtuelle maskinene og ESXi-verten til en stabil tilstand. Når du er ferdig, må du bruke BMC/iDRAC-strømkontroll og starte ESXi-verten på nytt for å få ESXi-verten til en stabil tilstand.

Du kan redusere nedetiden for de virtuelle maskinene før du starter ESXi-verten som ikke svarer på nytt. Registrer de virtuelle maskinene til andre stabile verter rett etter at du har slått av de virtuelle maskinene. (Deretter kan problemet startes på nytt av ESXi-verten).
Her er trinn for å registrere eller legge til en virtuell maskin (VM) i vSphere Inventory i vCenter Server.

Hvis du ikke kan slå av de virtuelle maskinene ved hjelp av SSH/RDP, kan du avslutte en virtuell maskin gjennom ESXi-verts-SSH-økten. Se Unable to Power off a Virtual Machine in an ESXi host (Kan ikke slå av en virtuell maskin i en ESXi-vert). 


Problemer med virtuell maskin: 

Kan ikke slå av den virtuelle maskinen i en ESXi-vert – 1014165

slår av en virtuell maskin som ikke reagerer på en ESXi-vert – 1004340

virtuelle maskiner vises som ugyldige eller utestengte i vCenter Server – 1003742

virtuelle maskiner ser ut til å kjøre eller registreres på flere ESX-/ESXi-servere – 1005051

en virtuell maskin som kjører, er utilgjengelig og mangler konfigurasjonsfiler – 2006648

Virtuelle maskiner blir utestengt etter omstart av ESXi-verten de befinner seg på – 2013301

slår på en virtuell maskin fra kommandolinjen når verten ikke kan administreres ved hjelp av vSphere Client – 1038043

Kan ikke slå på en virtuell ESX-/ESXi-maskin som tidligere fungerte – 1003648

feilsøke en virtuell maskin som har sluttet å svare – 1007819

kan ikke slå på en vertsbasert virtuell maskin – 1003671
 

Filrelaterte problemer med virtuell maskin: 

Gjenoppbygge den virtuelle maskinens .vmx-fil fra vmware.log – 1023880

Undersøke fillåser for virtuell maskin på ESXi – 10051 Kontrollere filintegriteten

til den virtuelle ESX-/ESXi-maskinen – 1003743

Article Properties


Affected Product

VxRail, VxRail Appliance Family, VxRail Appliance Series, VxRail Software

Last Published Date

13 Oct 2022

Version

3

Article Type

Solution