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RecoverPoint: Upgrading with Deployment Manager to 5.1.3 or later Fails After RPA1 is Reimaged

Summary: RecoverPoint: Upgrading with Deployment Manager to 5.1.3 or later Fails After RPA1 is Reimaged.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 

While attempting to upgrade RecoverPoint SE, EX or CL from 5.0.x or 5.1.x to 5.1.3 or later, Deployment Manager, (DM,) fails are applying the ISO file to RPA1.

RPA1 is left in a state waiting for a temporary IP address at the new code level if accessed using the CLI.  Replication should continue on the other RPAs within the environment while the system is in this state.

From the Deployment Manager dm.log file the following print is witnessed:

com.sun.xml.internal.ws.client.ClientTransportException: HTTP transport error: javax.net.ssl.SSLException: Received fatal alert: illegal_parameter

Cause

Deployment Manager instances that are being used to upgrade environments to 5.1.3 or later do not function properly when launched using Java 7 versions.  The failure is not instantaneous though.  

DM passes through the pre-checks and begin to upgrade RPA1.  It continues to run and function until it is required to connect to RPA1 where the ISO file has been applied and that RPA is now running 5.1.3 or later.  This is where the failure occurs and Deployment Manager stops.
 

Resolution

Workaround:

When upgrading to 5.1.3 (or later) version of RecoverPoint, ensure Deployment Manager is launched from a host running Java 8.  All versions and updates of Java 7 and lower should be avoided.

If an upgrade occurred using a version of Java that is lower than Java 8 and DM has encountered an error, the following process can be followed to resolve the situation:

  • Close Deployment Manager.
  • Uninstall or Upgrade to a version of Java 8 32 bit.  The latest is always best practice. (Run below command  in CMD to verify it shows Java 8).
    java -version
  • Launch Deployment Manager once again.
  • Resume the upgrade when prompted to do so.
If this does not resolve the situation, contact Dell Technologies support for further action items.


Resolution:

Dell Technologies engineering is investigating this issue. A permanent fix is still in progress. Contact the Dell Technologies Customer Support Center or your service representative for assistance and reference this solution ID.

Affected Products

RecoverPoint

Products

RecoverPoint
Article Properties
Article Number: 000168504
Article Type: Solution
Last Modified: 02 Oct 2024
Version:  4
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