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Dell Display Manager Application Will Not Work On A USB Only Connection

Summary: This article contains information regarding Dell Display Manager errors received when a USB-only monitor is connected to the computer.

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Symptoms

When a system is connected to a monitor via a USB connection only (instead of VGA, DVI, DisplayPort etc.), the following error will appear if the Dell Display Monitor (DDM) application is launched (Figure 1):

SLN284612_en_US__11381343357174.Display Manager Error
Figure 1: Dell Display Manager Error

Cause

The Dell Display Manager application relies on Display Data Channel (DDC) information. This information is not passed through a USB connection.

Resolution

In order to get the Dell Display Manager application to work correctly, the monitor must be connected a digital DDC-supported video cable like DVI-D, DVI-I, HDMI, DisplayPort (DP or mDP), or USB-C (that supports DisplayPort or Thunderbolt 3).

  1. Connect the monitor to the computer using a DVI-D, DVI-I, HDMI, DisplayPort (DP or mDP), or USB-C (that supports DisplayPort or Thunderbolt 3) cable.
  2. Download and install the latest device drivers. See the Dell knowledge base article How to Download and Install the drivers on a Dell Computer.
  3. If the above steps does not resolve the issue, contact Dell Technical Support for assistance.